All Questions

Filter by
Sorted by
Tagged with
0
votes
0answers
5 views

SVS.Build should not specify a version

Sitecore Visual Studio Project The package reference 'SVS.Build' should not specify a version. Please specify the version in 'xxx\Packages.props' or set VersionOverride to override the centrally ...
0
votes
0answers
12 views

Deploying SXA 10.2 XM Single with Sitecore Azure Toolkit 2.7 - The declared parameter 'Application Path" is not recognized

Installing XMScaled with modules is not working as expected. This did not work for XMSingle too. Followed the Walkthrough and inputs from Sitecore Azure Quickstart Templates {"code":"...
0
votes
0answers
32 views

Is it possible to have target "_blank" on image link?

Is it possible to send user to another page, for example in this case www.stackoverflow.com, when user clicks on the image? Basically right now, when someone clicks on the image itself it does not ...
0
votes
0answers
20 views

E-commerce demo [closed]

Is it possible to have a local version of sitecore commerce? Analogous to a standard Sitecore on a partner license to create a POC? I have not seen such a possibility anywhere.
0
votes
0answers
22 views

Server showing network related error - Sitecore 10 [closed]

Below error in Sitceore10.0.1. This was a sudden error. Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please ...
0
votes
0answers
8 views

base theme js and css files give 403

We enable optimizations for JS and CSS files and the optimized files comes from azure CDN but we found on app insights 403 requests for base theme files like GET /-/media/Base-Themes/Components-Theme/...
0
votes
0answers
8 views

Select A Rendering Not Recognizing Allowed Controls From Placeholder after App Pool Recycle

I'm experiencing an issue in Sitecore 9.0.2, Lucene index, and 10.2, Solr index, where some, but not all, of our placeholders in Experience Editor are not recognizing the renderings inside the Allowed ...
0
votes
1answer
29 views

installing SC Hotfix 513229-1.zip using Azure Pipeline

I want to install SC Hotfix 513229-1.zip for Sitecore XP 9.1.1. https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB1000489. I want to push this to Release Pipeline. I had done ...
0
votes
0answers
20 views

Debug Sitecore JSS React while SSR

How can I debug the JSS React application while using SSR, how to run the application with SSR in local machine with default npm commands?
0
votes
1answer
21 views

Content not shown in site after publishing [duplicate]

Sitecore 10.0.1 Published changes of one particular component is not showing up in site. The content is there in web db. And cache is also cleared and no error logs. Workflow of the item is also ...
2
votes
1answer
18 views

How to mock MediaManager in Sitecore using nSubstitute and xUnit

I am in the process of setting up some unit tests for a Sitecore project (using this guide as a starting point: https://www.codeflood.net/blog/2020/05/17/logicless-view-itemless-model/) I have come ...
1
vote
2answers
42 views

How to specify a datasource for a droplist field in sitecore 8.0 template

I am using Sitecore 8.0 where I have created a template with field droplist field type and I want to give datasource for it where it references another template datasource. And we have Multiple Sites ...
0
votes
0answers
35 views

How to create AD User in sitecore via custom API?

The Membershipprovider doesnt seem to create an AD user from custom c# API. While logging in via Azure AD sitecore automatically creates the AD user and maps the roles as per the transformation rules....
0
votes
0answers
13 views

Sitecore save check revision custom prosessor [duplicate]

For experience editor save issues, Sitecore provided a custom processor instead of the default one. So what are the steps to add the custom processor in sitecore like in which location to add the ...
0
votes
0answers
33 views

CHAP authentication attempt rejected due to expired or unknown challenge value

we are having an issue with unicorn sync run through octopus deployment process that is using MicroChap dll and shared secret. Everything was working fine and unicorn sync was working fine. Then we ...
1
vote
1answer
32 views

Adding a patch config file ONLY to my production server

So I have another question where I needed to add another target database to my sync in unicorn. However I only need the patch to take affect in my production environment since my local errors out on ...
0
votes
0answers
15 views

Skip or exclude standard fields from GraphQL query results

Is there a way to exclude or skip standard fields from GraphQL query results. I'm sure this has been asked before but I couldn't find any helpful information.
2
votes
1answer
44 views

How to mock an ImageField in Sitecore using nSubstitute and xUnit

I am in the process of setting up some unit tests for a Sitecore project (using this guide as a starting point: https://www.codeflood.net/blog/2020/05/17/logicless-view-itemless-model/) I have come ...
0
votes
0answers
22 views

Email Trigger In sitecore CDP

In sitecore CDP ,I have created connection for send email. this connection is triggerd but status is error. can anyone suggest me the way to run this email trigger successfully? Here is my response ...
0
votes
0answers
24 views

Sitecore CLI error on executing dotnet sitecore login

On running the below line in powershell script getting error PS C:\Devlopment\eKeystoneHelix\KAO> dotnet sitecore login --authority https://maj-testhelix.identityserver/ --cm http://maj-testhelix/ -...
0
votes
0answers
6 views

Extending Experience Analytics’ “Internal Search” to show page origin

We were already able to register search keywords via var pageEventData = new PageEventData(name, definitionId) { Data = data, Text = text }; interaction.CurrentPage....
0
votes
1answer
17 views

Supress MediaRequestProtection errors at site level

I have a multisite setup in sitecore 9.1 and getting the below error on ERROR MediaRequestProtection: An invalid/missing hash value was encountered. The expected hash value I know the reason for ...
0
votes
0answers
25 views

Sitecore SXA Cache not working for just one component

I have a page with few components on it, I have enabled caching for all the components and testing it using below line <!-- Cache Test for <Component Name>: Time = @System.DateTime.Now....
3
votes
2answers
130 views

SitecoreContext throwing error after Sitecore upgrade

I upgraded my dev instance from Sitecore 8.2 to Sitecore 9.3. My upgrade was successful but I am getting errors when I am trying to access my page. In our solution for getting the current page, we are ...
0
votes
0answers
12 views

Sitecore Azure search provider terms per facet configuration limit

Environment: SXA 10x, Azure PaaS. I am using Sitecore Azure Search provider which has a limit to return only 10 terms per facet by default on a query and SXA overrides it to 50 currently with 10x. ...
0
votes
0answers
16 views

"jss-main" was not found in the current rendering data while using node-headless-ssr-proxy with React

I am developing the JSS react template with node-headless-ssr-proxy for my company's solution, the react application have been migrated with Redux and dynamic routes, it can run and work normally in ...
0
votes
0answers
35 views

Sitecore 10.1 publishing stuck

We upgraded to Sitecore 10.1 from Sitecore 8.2. I am facing publishing issues. I have migrated master database content in Sitecore 10.1. The publishing of some sites to the web database are fine. Some ...
0
votes
1answer
28 views

Sitecore services client 403 when login called from different web application

TL;DR: Sitecore services client 403 when login called from different web application (IIS process), but not when called from Postman PROBLEM: RESTful Web API (web service) written in C# running on IIS/...
2
votes
1answer
62 views

Sitecore.LayoutService.dll version mismatch between NuGet and Headless Services package

On Sitecore 10.1.1, I've got Sitecore Headless Services Server XP 18.0.0 rev. 00473 installed. According to documentation, that's the correct version. The package brings Sitecore.LayoutService.dll ...
1
vote
1answer
38 views

config transformation in docker

We are currently working on migrating our Sitecore solution to docker. Earlier we were utilizing octopus for config transformation between CD and CM server roles and variable replacement between ...
2
votes
0answers
15 views

Retrieving EXM Automated send data

Is there a way to retrieve the data that was sent via automated messages in EXM? Specifically I would like: Contact ID Timestamp Message ID Tokens Message send status I have checked in the xDB ...
0
votes
1answer
53 views

Unknown argument "excludedFieldIds" on field "serialize" of type "Query"

Where can I find the excludedFieldIds argument? How to resolve? Unknown argument "excludedFieldIds" on field "serialize" of type "Query".(GraphQLException) the error is ...
0
votes
0answers
11 views

sitecorejss nextjs Coveo render error [closed]

I am trying to integrate coveo components in sitecorejss nextjs solution, coveo team has provided integration steps for reactjs application. But seems the components from coveo are not rendered ...
0
votes
0answers
41 views

Access Viewer HTTP 502

When trying to view user that has a lot of roles access via Access Viewer, Sitecore hangs then afterwards return an error message from hosting provider. This is the screenshot in network tab: This is ...
0
votes
1answer
25 views

Trying to add publishing database for Unicorn Sync when building

So I have two CD servers setup and seems like our Unicorn syncing is not completely setup because in the config it currently just has "web". So I need to add our "web_uk" CD to ...
0
votes
1answer
40 views

Sitecore Role Management customization [closed]

How to Access the sitecore.Context from my custom web api to manage the Roles? I am trying to connect to sitecore context using custom APIs.
0
votes
1answer
41 views

How to revert a package? [duplicate]

I want to install SC Hotfix 455749-1.zip for Sitecore XP 10.0.1. https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB1000580 says to install it from CM. So after installing it ...
0
votes
0answers
68 views

Sitecore Save Check Revision Custom processor

Using Sitecore 10 Experience editor save is not working. So i got a custom processor to use instead of the default one from sitecore support. I created a class and added the processor and also a patch ...
1
vote
0answers
50 views

Hard Time Creating mssql-init image with Multiple Modules on XP1

I'm trying to create an mssql-init image for XP1 that will install the following components: SPE module CH connector SXA module Coveo Coveo SXA I'll be using this to deploy to an Azure SQL server. I ...
0
votes
1answer
32 views

How can I import database from newer sqlserver version

I have a set of databases that is from SQLServer 2017 and I am trying to import the master and core databases into a SQLServer 2014. Also, it is on a Sitecore 8.2 U7 for both instances. Not sure if ...
2
votes
2answers
74 views

What is the best way to check if the Item is being inherited from a template?

I am using Sitecore 10.1 and I am upgrading my code from the Sitecore 8.2 solutions. I want to know the best practice to check if the Item is being inherited from a template? The requirement is to use ...
1
vote
1answer
23 views

Sitecore Role creation API

Is there a Sitecore Role creation API similar to item creation ? Can I map user to roles using Sitecore REST API?
0
votes
1answer
23 views

Permissions Exception Rebuilding Link Database

One of our users recently got this exception while trying to rebuild the links database it the Scan the database for broken links (report) dialog: I'm not clear what access is being denied here, and ...
0
votes
0answers
33 views

Cannot read properties of null (reading '1')

I am getting this error when I am trying to create a new theme using SXA CLI. ? Enter your login sitecore\admin ? Enter your password [hidden] ? Specify theme path. Root is Themes folder(format <...
0
votes
0answers
27 views

Experience editor does not save changes in sitecore 10 [duplicate]

Experience editor throws following errors in one page, it does not allow to edit the fields in other pages, after editing, when clicking on save a pop up with "Changes you made may not be saved.&...
1
vote
1answer
52 views

Products take 2-5 minutes to appear on site

I am working in a Sitecore Commerce 10. When I add a new product to the catalog, I can only see the new products after 2-5 minutes on the published site. Is there any way to reduce the time it takes ...
1
vote
1answer
33 views

How to add a multiline text fields values in a single cell of excel in Sitecore MVC

I am using Sitecore 8.0 . We have one Export of data feature using Excel. For all the fields the data is getting exported in a cell properly ,but for the Multiline text field the text is getting ...
0
votes
0answers
59 views

Editing fields in Experience editor not working

For carousel components, when hovered over text fields to edit, it does not show the cursor to edit. All other component fields are editable except this carousel field. Using Sitecore 10. This was ...
1
vote
1answer
27 views

Is there a way to render scriban templates without the use of SXA Rendering Variants?

I would like to do some quick prototyping of scriban templates but have found constantly changing the rendering variant and refresh the page to be more time consuming than I would like. Is there a ...
2
votes
1answer
18 views

How do you copy Latitude Longitude from the old SXA fields to the new Coordinate fields?

We are upgrading from an older SXA for Sitecore 8.2.7 to SXA 9.3. We would like to keep the Latitude and Longitude values intact but we have hundreds of items with this data. How can I migrate these ...

15 30 50 per page
1
2 3 4 5
215