All Questions

Filter by
Sorted by
Tagged with
0 votes
0 answers
21 views

Layout service response contains standard values instead of expected rendering data

I have an issue where my layout service will intermittently return standard values such as $name. There are a number of complicating factors such as load balancers, CDN, multiple content delivery ...
Marcel Gruber's user avatar
1 vote
2 answers
38 views

Sitecore Login with AAD Claim Transformation Not Working

I configured my local Sitecore instance to use AAD to login and everything seems okay except that my name and my email is not populated in the newly created user in Sitecore, but it correctly mapped ...
John Lee's user avatar
0 votes
0 answers
42 views

Error after backup restore [duplicate]

I am getting below error when I try to run the site after the web backup restore: ManagedPoolThread #5 15:57:18 INFO Job ended: Sitecore.ListManagement.Operations.UpdateListOperationsAgent (units ...
Bhawna Jain's user avatar
0 votes
0 answers
30 views

Unknown query node type: 'Constant'

We could see the lot of below exceptions in the Sitecore log file. Could you please provide some suggestions to resolve this issue? Exception: System.NotSupportedException Message: Unknown query node ...
Astle's user avatar
  • 411
0 votes
3 answers
29 views

Unpublish datasource items under Data folder in Sitecore SXA site

I am unpublishing item in Sitecore SXA. I have created an item with two rich text editor components. I have added the second rich text editor component and selected the datasource item from data ...
Ashu's user avatar
  • 402
2 votes
2 answers
74 views

How to migrate Sitecore forms to XM Cloud?

We have Sitecore forms in Sitecore 9.3 application. Now client wants to migrate application from SC 9.3 to XM Cloud. As Sitecore forms is not available in XM Cloud and not compatible with XM Cloud ...
Thamizh's user avatar
  • 317
1 vote
0 answers
24 views

How to patch javascript code in SXA SearchTheme

I am using Sitecore XP 10.2 with SXA. I encountered an issue in sxa search checklist filter. I have a facet that contains the '&' character and this is breaking the filtering of results. This ...
user3564042's user avatar
1 vote
2 answers
48 views

Sitecore Form is not working on my local instance, Sitecore version 10.2

I have a task to implement sitecore forms out of the box, and when I try to open the forms from the Desktop, it gives me the following error, any solutions? and the following text is a message from ...
Mahmoud  Elgazzar's user avatar
0 votes
1 answer
37 views

Custom Index Strategy Not Updating Indexes

We have a custom database named Preview and are able to publish to this, but the preview index is not getting updated when an item is published. If we manually rebuild via the CMS, the item will then ...
Kode's user avatar
  • 243
1 vote
2 answers
74 views

Source query For General Link Field Type

We need to use a source query for the General Link field type to display only the current page's data. In Sitecore XM Clould, is there any way we can achieve it from the front code (NextJs) as the ...
shrutika shete's user avatar
1 vote
2 answers
34 views

ERR_HTTP2_PROTOCOL_ERROR while changing the Layout in Sitecore Headless SXA 10.3

We are working on Sitecore 10.3 SXA (Headless with Next.js). While trying to change the layout of a site, we are getting (failed)net::ERR_HTTP2_PROTOCOL_ERROR while accessing the Layout Service. Are ...
Hari Prasad Kotha's user avatar
1 vote
1 answer
67 views

Context item on custom button click on richtext field

I added a button option along with edithtml on the click, I am calling and executing the powershell item:executescript(id=$Target,script={ACD773A7-93DC-49A8-8497-73CEEC9C5A9E},scriptDb=master) I am ...
Jagmeet Kaur's user avatar
1 vote
1 answer
29 views

File download fails between transfer

lately I'm encountering a weird issue with Sitecore 9.0.3. When I try to download a PDF file from the server, the transfer fails somewhere in the middle. It looks like a timeout. I tried to download ...
gtu's user avatar
  • 111
1 vote
2 answers
54 views

Can We Assign Different Taxonomies values to Different Language Versions of a Product in Sitecore Content Hub PCM?

For example, I have Product-A, and this product has a relation with the taxonomy "Country" which has multiple values. I want the English version of Product-A to be tagged with the taxonomy ...
Gautam's user avatar
  • 537
1 vote
1 answer
45 views

Pages behind authentication not being redirected to azure AD

I've been following this guide to enable SSO on our CM/CD instances to create virtual users via AzureAD. From what I can see it all looks fine but the redirect is not firing when a page is set to deny ...
Sean T's user avatar
  • 252
0 votes
2 answers
72 views

Getting error after login

I have restored master db from prod to local. Updated the connection string, but after I login, I see the below error. I have tried comparing my local's file with vanilla and even the one in prod. ...
Bhawna Jain's user avatar
0 votes
0 answers
45 views

How to Build a Custom Dropdown List Field That Retrieves the list from a Sitecore Bucket?

I am working on a Sitecore project and need to create a custom dropdown list field for Sitecore Forms that retrieves its options from an item bucket in Sitecore. Specifically, I want to populate the ...
KAcquah's user avatar
0 votes
0 answers
24 views

Error Boundary not working in Sitecore JSS with Next.js Project

I am using Sitecore 10.3.1 with JSS-Next.js app version 21.5.3 and Node version 21.7.3. My requirement is to handle client and server errors at the component level. I am currently using the "?&...
Saiprasad's user avatar
1 vote
1 answer
46 views

SOLR Not Working 503 Error Netty dependencies have versions that do not match the versions specified in the azure-core-http-netty pom.xml file

We have an Azure Web App SOLR connected with Sitecore for Indexing. it was working great till Yesterday. Now the Azure Service is Not coming up with Error. HTTP Error 503. The service is unavailable. ...
Sunil Rana's user avatar
2 votes
2 answers
78 views

Internal Link Not getting resolved in Cutsom RTE field Sitecore Form

I have custom RTE field in Sitecore form where I have used TextViewModel and the custom view below: @model Sitecore.ExperienceForms.Mvc.Models.Fields.TextViewModel <@Model.HtmlTag data-sc-field-...
Arun's user avatar
  • 21
1 vote
2 answers
41 views

Sitecore JSS: How to Hide Sitecore API Key in Client-Side JavaScript File

We have a Sitecore JSS server-side rendering mode, which uses Node.js and React.js as the tech stack. Unfortunately, the API key and API host are written in the JavaScript files. How can we avoid this?...
Andi AR's user avatar
  • 763
2 votes
1 answer
51 views

"Component GraphQL Query" field is ignored in Experience Editor

I installed the Sitecore 10.4 with Headless SXA and I noticed a strange behavior. On the components which has a "Component GraphQL Query" this field is ignored. On a 10.3 solution Link List ...
Vlad Iobagiu's user avatar
  • 18.6k
2 votes
1 answer
82 views

Rendering only visible on Content Delivery site after Azure App Service restart

Steps to replicate the problem: Add a new rendering with Personalization rules (we added this to our Footer Partial Design, but the problem surfaces when we add a rendering with or without ...
Harald Greve's user avatar
0 votes
3 answers
64 views

Multilist '__Standard Value' with child item

We have a branch template that creates multi-level items, i.e., a datasource item and child items (data items). The first-level item has a multi-list with the source set to the child items. Is there ...
Hari Prasad Kotha's user avatar
1 vote
3 answers
58 views

How to set page design SXA standard values

We are working in Sitecore 10.3 SXA. Is there any way to set the Page Design in __Standard Values for a page type template? Or is there any other way to set the Page Design automatically once an ...
Hari Prasad Kotha's user avatar
1 vote
1 answer
34 views

Brightcove Analytics on Sitecore 9.2 Website

We have integrated Brightcove with Sitecore, and our sites are gated. We have a requirement for videos to resume from where the user left off. We are attempting to achieve this using the following ...
Kritika's user avatar
  • 11
1 vote
0 answers
51 views

Has anyone experienced error getting Html.Glass().GetRenderingParameter<.....> on Sitecore 10.4

Using Glass Mapper Version 5 (Glass.Mapper.Sc.10 packages) on Sitecore 10.4. In cshtml views, I have this statement -> var renderingParams = Html.Glass().GetRenderingParameters<FNBOnline.Feature....
Jose Gonzalez's user avatar
1 vote
4 answers
349 views

Create item with Chinese and Japanese character

The requirement is to be able to create a Sitecore item with Chinese or Japanese characters in the item name. When I try to create an item with the name "美国律师协会" It shows an error that '...
Vinesh's user avatar
  • 151
1 vote
0 answers
33 views

Embed iframe tag in Content Hub Rich Text Editor

I am trying to embed the iframe tag into the Content Hub Rich Text Editor using internal Integration via script. The script replaces the placeholder key with an iframe tag in the Rich Text Editor ...
Himmat Singh Dulawat's user avatar
0 votes
1 answer
47 views

Archiving sitecore sites

I am working for a government client who have got their current websites developed in Sitecore. They are planning to move to other CMS and want to archive their Sitecore site. They have got ...
Raunak Basnet's user avatar
1 vote
6 answers
166 views

How to Fetch Only Template-defined Fields Using GraphQL

I'm currently using Sitecore GraphQL to fetch fields from a specific item in Sitecore. However, my query is fetching all standard fields along with the fields added in the template. I only want to ...
Gagan's user avatar
  • 45
1 vote
1 answer
165 views

ReCAPTCHA token is null on server side for invisible reCAPTCHA version 2

I'm trying to add the recaptcha invisible version 2 to the Sitecore form. I created the invisible recaptcha custom form element with the custom recaptcha validation I follow this article to add a new ...
mv98's user avatar
  • 23
1 vote
0 answers
39 views

Sitecore Multi-Zone Setup: Solr Index not Updating in One Zone during Indexing

Title: Sitecore Multi-Zone Setup: Solr Index not Updating in One Zone during Indexing Sitecore setup with 4 CD servers configured into two zones: zone-a and zone-b zone-a: servers 01a and 02a zone-b:...
Harish's user avatar
  • 129
0 votes
1 answer
54 views

Custom boosting rule for scopes to boost by time passed since last update

I am trying to implement a custom boosting rule (as described here) for the site search scope, where an item should be boosted by the time passed since last updated. For the record - we already ...
z00mable's user avatar
  • 621
1 vote
1 answer
66 views

Publishing Service Dashboard is empty

We have Sitecore 10.3.1 installed and setup, with Sitecore Publishing Service 7.0.20 and Sitecore Publishing Service Module 10.3.0. Publish itself works fine for all targets: items have appeared in ...
S. C.'s user avatar
  • 11
1 vote
1 answer
44 views

How to handle transient errors from Sitecore IP Geolocation service

We have been using the Sitecore IP Geolocation service for over 3 years. During that time, when making calls to Sitecore.Analytics.Lookups.GetInformationByIp(), we have seen various instances of ...
Marcel Gruber's user avatar
1 vote
1 answer
66 views

Add IdentityServer back to Sitecore 10.1.2

We had sitecore local dev instance using /sitecore/login without using identityserver and we need to add the identity server back. Here are steps I did in one VM and it worked fine: Get the https://...
John Lee's user avatar
1 vote
0 answers
23 views

Unable to Send FileUploadUrl in Email While using out of the box fileupload control in sitecore forms(sitecore 10.3.1)

I am using out of the box File Upload Control. While exporting the form data I receive all the fields with a file upload URL which will download the file. I am trying to send these details over email. ...
sriharsha kathri's user avatar
1 vote
1 answer
35 views

Content Hub External component get user rights

In Content Hub DAM I want to create an external component, but want to be able to show or hide information based on the user permissions. Everyone is able to see my entity, but not everyone is allowed ...
Danny Paul's user avatar
2 votes
0 answers
29 views

How to split JS bundles by page

On our JSS/Next.js site, we are running into an issue issue with poor PageSpeed performance scores, which are mostly attributable to large JS bundles. They're so large because we have one large main....
Marcel Gruber's user avatar
1 vote
3 answers
63 views

Filtering Entities based on the Content associated with them

I have created a custom Brand entity and designed both its Search and Details Pages. There is a relationship between M.Asset and Custom Brand. I aim to show only those Brands on Brands Landing page ...
girish jain's user avatar
4 votes
2 answers
116 views

Language options suddenly disappears in Publish Dialog

We are currently using Sitecore 10.3 XM in containers. After deploying on the CM environment, we have noticed that the languages option does not appear in the publishing dialog on some lower and ...
Akshay Barve's user avatar
0 votes
2 answers
29 views

What is the relationship between Sitecore index to Solr index core?

I was able to deploy Sitecore 10.3.1 in Azure and I verified the solrConnectionString is pointed to my Solr installation https://mydomain.com:8983/solr. I understand when we deploy onprem locally, ...
John's user avatar
  • 91
0 votes
1 answer
26 views

The new fields that added to template not appear on GraphQl schema on CD server

I am using Sitecore 9.3 with JSS, I faced issue that when i add new field on template and try to retrieve it using GraphQl Query , it is coming on CM, but gives me error on CD "message": &...
shimaa elsayed's user avatar
1 vote
0 answers
48 views

Sitecore 10 ExperienceForms on Form Submit not inserting data into Database

I have built a Sitecore 10.1 form with multi page level which includes upload file and google captcha. On submit Button I have attached the following action (Save Data, Send Email with Attachment, ...
Mamtha's user avatar
  • 21
0 votes
1 answer
45 views

Hierarchical/Nested Facets

How can we return facets as a hierarchy? 1. knowledge_area -Knowledge area 1 -Knowledge area 2 -Knowledge area 3 -Knowledge area 4 -Knowledge area 5 2. study_field -Study ...
Godiez's user avatar
  • 11
0 votes
1 answer
29 views

How to supply solrConnectionString when deploying Sitecore 10.3.1 to Azure?

I created a VM and installed the Solr 8.11 and added public IP address and certificate to make Solr accessible from outside the VM as https://mydomain.com:8983/solr - url tested and it is working. I ...
John's user avatar
  • 91
0 votes
1 answer
36 views

Placeholder item in Swiper slide

We are using SwiperJs for the carousel. There is a placeholder with multiple items and I want to render each item of the placeholder in a SwiperSlide. How can I render? I am trying to achieve it in ...
SSC's user avatar
  • 1
0 votes
1 answer
47 views

Sitecore DR Database Question

Setup: Hello I have a DB question regarding setting up Sitecore 10.3 in Azure app service in an active/active configuration for DR. The idea is for CD instances in site A and site B (different zones) ...
ev0s's user avatar
  • 101
0 votes
0 answers
37 views

Sitecore SolrCloud: Main alias not updating after index rebuild

I'm using Sitecore SolrCloud, and I have encountered an issue with the index rebuild process. Here's what happened: I inadvertently deleted index records from both the main and rebuild aliases in my ...
Harish's user avatar
  • 129

15 30 50 per page
1
2 3 4 5
263