3 of 4 added 66 characters in body

Yes its actually very simple. You need to set the following settings:

  • Xdb.Enabled set to false
  • Xdb.Tracking.Enabled set to true

That will disable Xdb, but still allow the personalization rules to run on renderings.

Note that this applies to 8.1 and above only. In 8.0 you would have to keep Xdb.Enabled set to true and remove the MongoDb connection strings. It will generate a lot of errors in the logs and is not a supported way of running it. But it does work.

Disabling xDB like this means, you do not need an xDB license.

Reference: Sitecore in CMS Only Mode