9 votes
Accepted

How to use an ARM Template to deploy WFFM into a staging slot?

So, I managed to figure out what I was doing wrong. Finally. There were 2 big issues with my code: The naming of an item is seriously important and has a few different purposes, especially in the ...
  • 505
5 votes
Accepted

Sitecore PaaS using ARM templates throws "Master DB User Name is not recognized"

After some troubleshooting, the error was expected as I used the same Sitecore package for different roles. "cd.msdeploy.packageurl": { "value": "https://mysitecorestorage.blob.core.windows.net/...
5 votes
Accepted

SQL user creation is setting password of 12345, fails deployment

I found the problem. The 9.0.1 parameters.xml file in the Sitecore 9.0.1 rev. 171219 (Cloud)_xp1collection.scwdp.zip has a parameter for Messaging Database Application User: <parameter name="...
3 votes
Accepted

FXM web index is missing with Sitecore Azure PaaS

I have finally got a response from Sitecore: There is an inconsistency in Sitecore documentation regarding sitecore_fxm_web_index. Our documentation team is working to fix this inconsistency. ...
  • 19k
2 votes

SQL user creation is setting password of 12345, fails deployment

FYI, and in case it could help, the new Sitecore ARM Templates just had been released here: https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates with this commit: https://github.com/...
1 vote
Accepted

Modify XPSingle ARM template

Required things to do: Adapt WDP to remove CD role Create a seperate WDP with just the CD role Modify the nested/application.json to deploy the new cd Optionaly you might want to adapt ...
1 vote
Accepted

'Microsoft.Web.Deployment.DeploymentException: The path '' is not valid for the 'dbFullSql' provider

FYI, and in case it could help, the new Sitecore ARM Templates just had been released here: https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates with this commit "Support for Sitecore 9.0 ...
1 vote

'Microsoft.Web.Deployment.DeploymentException: The path '' is not valid for the 'dbFullSql' provider

I ran into this today, too. It's because there aren't any values being passed to the web deploy package for the EXM database values. EXM has been added to 9.0.1 but wasn't part of 9.0.0. I ended up ...
1 vote

FXM web index is missing with Sitecore Azure PaaS

I had the same issue with some of the web-indexes. The indexes I was missing were: sitecore_web_index sitecore_marketingdefinitions_web sitecore_marketing_asset_index_web sitecore_fxm_web_index ...
  • 533
1 vote

How to use an ARM Template to deploy WFFM into a staging slot?

CAVEAT: I haven't actually any of these suggestions, so I might be off the track here, but there are two things that look like they might need attention to me: I think it's a bad idea to try to put a ...

Only top scored, non community-wiki answers of a minimum length are eligible