7

So, I managed to figure out what I was doing wrong. Finally. There were 2 big issues with my code: The naming of an item is seriously important and has a few different purposes, especially in the case of child resources. It is impossible to update a resource in the same template due to the unique naming restriction. For point 1, it is also important to ...


5

After some troubleshooting, the error was expected as I used the same Sitecore package for different roles. "cd.msdeploy.packageurl": { "value": "https://mysitecorestorage.blob.core.windows.net/xpscpackages/Sitecore%208.2%20rev.%20161221_cd.scwdp.zip" }, and "prc.msdeploy.packageurl": { "value": "https://mysitecorestorage.blob.core.windows.net/...


5

I found the problem. The 9.0.1 parameters.xml file in the Sitecore 9.0.1 rev. 171219 (Cloud)_xp1collection.scwdp.zip has a parameter for Messaging Database Application User: <parameter name="Messaging Database Application User Name" description="Messaging Database Application User Name" defaultValue="messaginguser" tags=""> <parameterEntry type="...


3

I have finally got a response from Sitecore: There is an inconsistency in Sitecore documentation regarding sitecore_fxm_web_index. Our documentation team is working to fix this inconsistency. FXM requires that both sitecore_fxm_web_index and sitecore_fxm_master_index are enabled in CM environment. It will take some time until existing WDPs are ...


2

FYI, and in case it could help, the new Sitecore ARM Templates just had been released here: https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates with this commit: https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates/commit/d258f794489abc3e56c67f27af708b519cc157d3


1

Required things to do: Adapt WDP to remove CD role Create a seperate WDP with just the CD role Modify the nested/application.json to deploy the new cd Optionaly you might want to adapt infrastructure.json to create a seperate appserviceplan for your cd. You could also inverse the method by starting from the XP-Scaled and then bundling the reporting and ...


1

FYI, and in case it could help, the new Sitecore ARM Templates just had been released here: https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates with this commit "Support for Sitecore 9.0 Update-1": https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates/commit/d258f794489abc3e56c67f27af708b519cc157d3


1

I ran into this today, too. It's because there aren't any values being passed to the web deploy package for the EXM database values. EXM has been added to 9.0.1 but wasn't part of 9.0.0. I ended up adding these values into the cm web app MSDeploy setParmeters in the application.json file: "EXM Master DB User Name": "[parameters('exmSqlDatabaseUserName'...


1

I had the same issue with some of the web-indexes. The indexes I was missing were: sitecore_web_index sitecore_marketingdefinitions_web sitecore_marketing_asset_index_web sitecore_fxm_web_index social_messages_web These are all defined in configuration files that are only deployed to the CD instances by the ARM templates. By default none of the indexes ...


1

CAVEAT: I haven't actually any of these suggestions, so I might be off the track here, but there are two things that look like they might need attention to me: I think it's a bad idea to try to put a "/" into a resource name, since this is the delimiter for resource URIs. I'd be tempted to use something like "MSDeploy.1" and "MSDeploy.2", but I'm not clear ...


Only top voted, non community-wiki answers of a minimum length are eligible