10

I asked this exact question 6 months ago and this is the complete response I received from the Sitecore Training team via "FreshDesk": Sitecore Professional Developer - This examination is for Version 8.2 Sitecore Certified Platform Associate Developer - This is for Version 9.0 They also referenced a ticket: https://sitecore.freshdesk.com/...


10

Just remove or disable these two files: \App_Data\Config\sitecore\CoreServices\sc.XConnect.Security.EnforceSSL.xml \App_Data\Config\sitecore\CoreServices\sc.XConnect.Security.EnforceSSLWithCertificateValidation.xml This is only for the development purposes, of course.


8

Check the following possible areas to figure this out Make sure thumbprint on the key xconnect.collection.certificate in connection string config file matches with the thumbprint found in corresponding xconnect site App config(C:\inetpub\wwwroot\site.xconnect\App_Config). Verify the thumbprint of xconnect client matches with the thumbprint provided in ...


6

The text you reference from the Exam Study Guide was at one point the intended structure for the certification program. There was a desire to create different levels, with Associate at the initial level, and Certified Professional being a second level that could be achieved. It remains to be seen if this will occur in the future. At the time of this ...


5

OOTB Sitecore XC installation needs a Root Certificate as it creates self-signed certificates for your storefront website. If you are planning to use different server certificates than OOTB self signed certificate, you can remove related tasks from installation script. If you want to continue with default installation, you can do following: - check folder c:...


4

Assuming it's expired you can easily create a new certificate using Windows Powershell by running the following command(so no need of SIF just for that part): New-SelfSignedCertificate –DnsName "ComputerName" -CertStoreLocation cert:\LocalMachine\My This is for self-signed certificates. After you run that you will get the thumbprint of it, so just make ...


4

If you are receiving this error it means you either have the wrong certificate's thumbprint referenced in your configs (or the thumbprints are not all the same), or the user account of the IIS AppPool used for the commerce services does not have correct access to the certificates. How to check you are using the right thumbprint: The certificate/thumbprint ...


4

I wrote about this troubleshoot a few weeks ago, but here are the main steps: 1. Make sure you have the rights certificates on the right places: Local Computer Certificates Trusted Root Certification Authorities: DO_NOT_TRUST_SitecoreRootCert with private key Personal: One certificate for your xConnect website issued by DO_NOT_TRUST_SitecoreRootCert ...


3

You can override UrlAgent that is used to make keepalive.aspx call. And disable certificate validation: System.Net.ServicePointManager.ServerCertificateValidationCallback = ((sender, certificate, chain, sslPolicyErrors) => true); It is configured in Sitecore.config: <agent type="YourNamespace.YourUrlAgent" method="Run" interval="00:15:...


3

Figured it out. This annoying setting was missing "Incoming Client Certificates".


3

It looks like there is an XML instead of a config file on which we can do it. website.identityserver\Config\production\Sitecore.IdentityServer.Host.xml <Settings> <Sitecore> <IdentityServer> <CertificateThumbprint>‎ABCB50CAB808CDD021A9850CF6BB8AA2B6A1B3AD</CertificateThumbprint>


2

The final piece to the puzzle was to make sure that I had the cert installed on my sitecore box as well - local machine > trusted root CA. I realized that after I took a pass over this blog: http://www.kurbegovic.com/blog/sitecore-9-multi-server-installation-part-2-solr-server-setup/ Thanks.


2

I totally forgot to update the question: According to Microsoft document the problem was that the certificate has to be signed by a trusted certificate authority.


2

Based on the code in CertificateHttpClientHandlerModifier the certificate should have been loaded. However, you can create your own certificate handler by implementing IHttpClientHandlerModifier. public class CustomHandler : IHttpClientHandlerModifier { public void Process(HttpClientHandler handler) { X509Certificate cert = ...


1

Could not load device 'ea07cc63-1d43-437e-86b8-9fec30bae95f' - This ID is the analytics cookie id set in your browser. Sitecore is trying to search for above id in xDB to find if you are the existing visitor or new visitor. sitecore was unable to connect to xDB due to incorrect credentials in your connection string config file for xdb.collection....


1

So after revisiting this fresh, embarrassingly the logs also showed messaging about the GET request to an address that was local to the server (from my installation). I'd since updated with non-local DNS and must not have saved my change to the /Config/Sitecore.Horizon.API.Gateway.config file with the publically accessible url within this tag: <...


1

You can try searching the old certificate thumbprint in the Horizon website folder. Next, replace this with new certificate thumbprint. Check if this works


1

Most of the time I see this error, the issue is with the license. The license needs to be: Up to date Valid Xml Includes the key xDB.Base. XDB.Base signifies that the license is valid for xDB.


1

You should generate new cert and use it. It's not recommended to allow invalid client certs especially on Prod. They are used for authentication so make sure client cert is valid and AllowInvalidClientCertificates is set to false.


1

Short answer - Yes! If you've generated a new Root Certificate, you need to create a new certificate for xConnect_client in-order to maintain the Signer relationship with the Root Certificate. PS: Also, Don't forget to add the App Pool user permission on certificate and update the latest Thumbprint of the new certificate under AppSettings.config (of ...


1

It seems that you have not installed client certificate on app service from which you are trying to connect to xconnect. Go to connectionstring.config of your website and note thumbprint of the certificate Go to app service where you are running this code and navigate to TLS/SSL settings and then click on Private Key Certificates (.pfx) You should be able ...


1

I think this is more than a generic SSL or IIS question, not a Sitecore one. but from StackOverflow - https://stackoverflow.com/questions/10440806/how-to-renew-an-iis7-self-signed-ssl-certificate simple answer is - No, it's not possible. Because you have chosen to use a self-signed certificate that you have explicitly configured to be trusted in your ...


1

OOTB IdentityServer.json needs a certificate name, that certificate name is used to create a Server+Client authentication certificate, and that certificate is further used for following: HTTPS binding in IIS for Identity Server website. Thumbprint of certificate used inside configuration of identity server. See "CertificateThumbprint" setting value in file {...


1

According to this StackOverflow article, it should be possible using the same steps, but skipping the generation parts. The Java truststore and keystore files are the same regardless if its self-signed or CA-signed certificates. Using the instructions from your CA, import the appropriate certificates to the truststore and keystore that Solr will ...


1

Can you please try below two fixes. Check client certificate Thumbprint value in config file is maching with the certificate Thumbprint. Give certificate access to app pool user.


1

Please check the below things. 1- Check the connection string on ServerB and check "xconnect.collection.certificate" has the same thumbprint that you have for Xconnect certificate on ServerA. 2- Make sure your server certificate (SSL) for XConnect is valid and can be validated from ServerB. 3- run MMC and check that certificate is exist in your local ...


1

There are some bugs in SIF 1.x's certificate generation that were fixed in SIF 2.0. This meant that some of the configs from SIF 1.x caused problems with SIF 2.0 due to workarounds in the 9.0.x configs. SIF 2.0.0 on SC 9.0.2 - "The operation is on user root store and UI is not allowed" Has some solutions for this.


1

You also need to add the xConnect App Pool user to the new certificate via Manage Computer Certificates MMC. Right-click on the new cert then > All Tasks > Manage Private Keys. Add the xConnect App Pool user there.


Only top voted, non community-wiki answers of a minimum length are eligible