9

This is a known bug: https://kb.sitecore.net/articles/828414 Solution Install a hotfix corresponding to your Sitecore Experience Platform version: For Sitecore XP 9.0 rev. 171002 (Initial Release): https://dl.sitecore.net/hotfix/SC Hotfix 204620-1 Sitecore CES 2.1.0.zip For Sitecore XP 9.0 rev. 171219 (Update-1): https://dl.sitecore.net/hotfix/SC Hotfix ...


2

Generally, checking for bots through the User Agent is not very accurate as it can be easily forged. Use Robot Detection Using the Robot Detection feature from Sitecore Analytics, you will have more accurate results as it doesn't only analyze a single request but considers the visitor's behaviour during the current session. By default, on the first page ...


2

Setting up a proxy from my web.config solved the issue. Traffic sent through the proxy got access to the database service and the device cache was formed. Was able to see devices in Sitecore analytics afterwards. <system.net> <defaultProxy> <proxy usesystemdefault="true" proxyaddress="http://YOURPROXYHERE" bypassonlocal="true" ...


2

In the sitecore/Settings folder, set DeviceDetection.Enabled to true Add the enable Sitecore.CES.DeviceDetection.config file in the (App_Config/Include/CES/) folder


1

I've used below code and it's working fine: var deviceInfo = DeviceDetectionManager.GetDeviceInformation(Request.UserAgent); var myDevice = deviceInfo.DeviceType;


Only top voted, non community-wiki answers of a minimum length are eligible