4

Ok, having spent some time trying to figure out how this whole thing works in Sitecore, I can now say, that SXA-JSS does not support integrated GQL. The problem lies in the sxa-jss configuration for the LayoutService, which is selected by default when you create a new SXA JSS site. The configuration above comes from this file: \App_Config\Modules\JSS SXA\...


4

1) In your Layout you can add div which will be rendered only when page is opened in Experience Editor. You can use this condition in your code - Sitecore.Context.PageMode.IsExperienceEditor. You can then style this div to push content down so it's not overlapped by Ribbon. 2) When you are using position: fixed or position: sticky for your header, Richard ...


4

Versioned layouts make it possible to specify different layouts for different versions and languages of the same item. In the Standard fields of a versioned item, in the Layout section, two fields are for layouts: __Renderings – a shared field where you specify the common layout for all languages and versions of the item. __Final Renderings – a versioned ...


3

It's completely different in Experience Editor. When you click on any of the versions, there is a request to /-/speak/v1/ExperienceEditor/SelectVersion.js It builds an url for selected version, checks if the item has presentation details and finally it calls code similar to: var url = ExperienceEditor.Web.setQueryStringValue(ExperienceEditor....


3

This can happen if you have made your SXA Tenant unpublishable. There seems to be some logic in some components that doesn't resolve the Context (master/web) correctly and needs to have the site published. Simply make your SXA Tenant publishable (remove publishing restrictions) and publish to resolve this issue.


3

If we combine what @nsgocev wrote in his comment and what I wrote in mine, we have the following answer: create a duplicate of /sitecore/shell/client/Business Component Library/Layouts/Renderings/Common/MessageBars/MessageBar.cshtml file and change the text: binding to html: binding in every line containing data-bind="text: text, attr: { title: text }" find ...


3

This was an issue in the initial release of the ASP.NET Core SDK (14.0.0). It is resolved in 14.0.1, which is referenced in version 1.0.1 of Sitecore.DevEx.Templates. To install latest template: dotnet new -i Sitecore.DevEx.Templates --nuget-source https://sitecore.myget.org/F/sc-packages/api/v3/index.json If you have an existing template instance, you can ...


2

There is a setting Preview.ResolveSite in Sitecore.config. If true, when a user previews an item, Sitecore tries to resolve the root item and the context site based on the current content language and the path to the item. If Sitecore cannot resolve the context site, it uses the site that is specified in the Preview.DefaultSite setting. ...


2

I had the same issue, I solved it by writing query: in front of /sitecore/Forms in the Datasource Location, so that the datasource location says query:/sitecore/Forms


2

If you check the enablePreview property under Sitecore.config file. It should be set to true like this. <site name="website" enableTracking="true" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content" startItem="/home" language="en" database="web" domain="extranet" allowDebug="true" cacheHtml="true" htmlCacheSize="50MB" registryCacheSize="0" ...


2

You may not able to just prevent the "Datasource Location" field alone to be overwritten. Because the pipeline "ProcessRenderings" in .\App_Config\Sitecore\JavaScriptServices\Sitecore.JavaScriptServices.AppServices.config updates this. This is the one which creates renderings and other mandatory process for renderings as well. <pipelines> <...


2

@john, look into your Site Groupings for SXA. This sounds like a case where the web editing functionality isn't available for your page for your site grouping and it's falling to another site grouping or the website site. Ensure that you have Site Groupings that are appropriate for the page that specify the correct database and editing options that you'...


2

This is a known bug in Sitecore 9.1. You can create a ticket with Sitecore Support to obtain the hotfix patch. You can refer to public reference number 315995.


2

I think there is some confusion here about how the template inheritance works in Sitecore. Let's say you have Template B with Field BB, and Template A that has Field AA. Template A also inherits Template B. Now when you create a Page based on Template A, the page will have 2 fields, AA and BB. To read those fields, you would just get the Page item: var ...


2

You can check if page is opened experience editor mode. @if (!Sitecore.Context.PageMode.IsExperienceEditor) { <!-- Header Markup --> }


1

Assuming your code is triggered in an event, you could use an EventDisabler in your code: using (new EventDisabler()) { ... } Or (still in the assumption your code is in an event) you could use the optional parameters of the EndEdit() to do a silent save: use it like EndEdit(false, false) in your case. This will use silent mode (which actually just is ...


1

It should be enough to compare if what you want to set to other versions is really different from what is in your current language version. And only in that case start editing the item. See the code below: public static void ApplyVersionToOtherLang(Item savedItem) { if (Sitecore.Context.PageMode.IsExperienceEditor) { var ...


1

Turns out we were using a SuperFieldEditor for our X-Editor to provide access to the template fields for the component. Super Field Editor So I fixed the issue by disabling Field access to all authors. Now it was little tricky since I wanted to write to the field, but not allow read. Here's what I ended up setting. Works!


1

I don't think this is something your going to be able to achieve with custom experience buttons. Generally the order of the display of fields in a component is fairly fixed so this would be a bit of an odd approach / concept for Content Editors. You have 3 options here I think: Option 1 - Create a new instance of a component where the text is above the title ...


1

Please change requestValidationMode="4.0" to requestValidationMode="4.5" in web.config file. It was working for me.


1

The default state should not have a selected content item. It should be empty. The component will use the data source that was selected when you set-up the component. The UI is a little misleading. Select your default content when you drop the component on the page. Then set-up your personalization conditions. It should work then.


1

This is the case where you need to use Field editor button, basically you can define a field editor button in core database, you can define the fields you want to be edited, then associate this button with your rendering, following are the steps: Switch to core database and navigate to this path: /sitecore/content/Applications/WebEdit/Custom Experience ...


1

Create a new custom template for comments. Assign this template to the respective workflow command in the Comment Template field Now you can see your customized dialog


1

I would recommend using separate browsers. I use one for the sitecore shell and one for testing (i.e. firefox and chrome). I find this to be much less troublesome when it comes to cookies, etc. But that's my personal preference to avoid the issue. You can use incognito too.


1

This is the case where you need to use Field editor button, basically you can define a field editor button in core database, you can define the fields you want to be edited, then associate this button with your rendering, following are the steps: Switch to core database and navigate to this path: /sitecore/content/Applications/WebEdit/Custom Experience ...


1

Please find the hotfix available at the following URL: https://sitecore.app.box.com/s/hab14a1l671cly284pe15io20q0bzayz Be aware that the hotfix was built specifically for Sitecore XP 9.3, and you should not install it on other Sitecore versions or in combination with other hotfixes, unless explicitly instructed by Sitecore Support. Note that you need to ...


1

This issue occurs if the Sitecore Identity Server provider is installed, but it has been disabled. The Sitecore Identity Server provider is enabled by default in Sitecore 9.1+ installations, but it can be disabled for example using the Sitecore.Owin.Authentication.IdentityServer.Disabler.config.example configuration file, provided as example in the \...


1

I think I figured it out! Sitecore is merging messages with the same text, so making the message unique to the validation failure fixes the error. Originally I was setting the error message text as follows in the parameters section of the validator item: Instead of doing this, I am now setting the message within the custom validator itself as follows: this....


1

What you want can be done like this: <h2>@Model.Title</h2> <div>@Model.Paragraph</div> <hr /> @foreach (Sitecore.Data.Items.Item section in Model.Sections) { @Html.Sitecore().Rendering("/sitecore/layout/Renderings/MySectionsRendering", new { DataSource = section.ID }); } Side note: I do encourage you to ...


1

I was able to resolve this issue. You will need to change sitecore\shell\client\Sitecore\ExperienceEditor\Commands\ShowDataSources.js. Search for line: this.command.context.app.showNotification("notification", notificationTitle, true); and replace it with: this.commandContext.app.showNotification("notification", notificationTitle, true); After this fix ...


Only top voted, non community-wiki answers of a minimum length are eligible