6

Something like this has worked for me. Beyond the boosting, the important part is to have the exact match Or the loose match. exactPredicate.Or(loosePredicate); That will build the proper SOLR query. { var parentPredicate = PredicateBuilder.True<ContentPageSearchModel>(); var exactPredicate = PredicateBuilder.False<ContentPageSearchModel>...


5

There are a few steps involved in order to troubleshoot and fix this issue. Step 1: The first step would be to check what index update strategy is used for sitecore_core_index. You can search for <index id="sitecore_core_index" on /sitecore/admin/showconfig.aspx page, <strategies node. By default, IntervalAsynchronousStrategy index update strategy is ...


5

You're missing name param xml element. Documentation says: The configuration is similar to what is described for Solr, except for this: And then that part of your configuration is added. You need index configuration with the following parameters: string name, string mainalias, string rebuildalias, string activecollection, string rebuildcollection, ...


5

Some of the steps that can be followed to increase the performance of Solr indexing are: Limit the items getting into Solr: You can limit the number of items that are getting indexed by changing the <Root>/sitecore</Root> parameter in Sitecore index configuration file. Stored Vs Indexed: Not all fields needs to be both Stored as well as ...


4

To rebuild indexes from sitecore powershell you can use below script which will re-index all indexes one by one using namespace Sitecore.ContentSearch $indexes = [ContentSearchManager]::Indexes foreach($index in $indexes){ Write-Host "Re-indexing started " $index.Name $index.Rebuild([IndexingOptions]::ForcedIndexing); Write-Host "Re-indexing ...


4

This is how text fields work, it's a tokenized search.. If you are looking for an exact string match, you should be using returnType="string" in your index configuration. Beware as well that you should not be using _t in your code as that hardcodes the Solr field type. You should also change that in your code to just [IndexField("email")]. This should be all ...


3

Segmentation rules ONLY work against xDB contacts. If you have any properties in the user profile (aka asp.net members profile properties), then this will never work. You need to push those properties to a custom xDB facet. Segmentation rules are just predicates that are added the xDB search query.


3

Did you try populating Solr Managed Schema from Sitecore Control Panel? After creating a custom index in Solr and configuration file in Sitecore, this should be the next step. Once successfully populated, try rebuilding the index.


3

This is done as part of the extraction of the content of media items for the _content field. See for example Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config where it has the type Sitecore.ContentSearch.ComputedFields.MediaItemContentExtractor,Sitecore.ContentSearch. The file mapping is done in the node at contentSearch/indexConfigurations/...


3

After investigating I found that this error occured in Avatar facet. It looks like sitecore indexer bug. This issue happens when image for avatar has a big/medium resolution. Image data (byte[]) is big and as I understand there are some limits in JsonReader or somewhere else. After many attempts I found that 128x128 jpeg image is OK and error dissappears, ...


3

You could call the Azure Search Rest API directly to query the index-catalog Example request: GET xxx.search.windows.net/indexes/index-catalog/docs?search=*&$filter=sitecorename eq 'sitecore_web_index' Result: { "value": [ { "@search.score": 1, "key": "SITECORE_WEB_INDEX-SEARCH", "sitecorename": "...


3

You query looks fine, but be sure that you did following steps: Enable IndexPIISensitiveData for xConnect in xconnect.instance\App_Data\Config\Sitecore\SearchIndexer\sc.Xdb.Collection.IndexerSettings.xml Enable IndexPIISensitiveData for IndexWorker in xconnect.instance\App_Data\jobs\continuous\IndexWorker\App_data\config\sitecore\SearchIndexer\sc.Xdb....


3

As you are using SXA, why not use the "ootb" option to add extra fields that include data from a linked item: The doc here is talking about facets, but the main purpose is actually creating an index field: https://doc.sitecore.com/users/sxa/93/sitecore-experience-accelerator/en/extend-search.html#UUID-3cbc7b12-9aed-f7d2-cd98-...


2

Sitecore configs are case sensitive. Your config contains returntype with lowercase t character. It should be returnType with capitacl case T. <fieldNames hint="raw:AddFieldByFieldName"> <field fieldName="contentheading" returnType="text"/> <field fieldName="contentintro" returnType="text"/> <field fieldName="startdate" ...


2

There used to be ExcludeField method in ProviderIndexConfiguration in older Sitecore version. It was just calling DocumentOptions.AddExcludedField as Matthew Dresser wrote in his comment. At some point it was marked as obsolete and finally it was removed. In Sitecore 9.1.0 rev. 001564 dll method ExcludeField is no longer there. AddExcludedField of ...


2

I answered a similar question here, but I'll paste the answer I came up with in case anyone stumbles upon this. You're really close. You have to queue up the context first and then add and commit. using (var solr = ContentSearchManager.GetIndex("my_index')) { var ctx = solr.CreateUpdateContext(); solr.Operations.Add(newItem, ctx, solr.Configuration)...


2

What I had to do was visit this URL: https://solr:####/solr/name_of_index_core/update?commit=true&stream.body=<delete><query>*:*</query></delete> Then I had to: Restart the solr service Restart Sitecore Repopulate schema Reindex Though there might be some extra unnecessary steps in there, the amount of documents and indexed ...


1

I think your <mapFieldByFieldName hint="raw:AddFieldReaderByFieldName"> needs to be inside the <fieldReaders type="Sitecore.ContentSearch.FieldReaders.FieldReaderMap, Sitecore.ContentSearch">...</fieldReaders> section. Result of that section would be: <fieldReaders type="Sitecore.ContentSearch.FieldReaders.FieldReaderMap, Sitecore....


1

Item name (_name) field in lucene/solr is defined as text type, so it is stored as a tokenized value in search indices. So when you search using name, (query will be formed like _name:(alumni)) it will return all items which contains "alumni" in name. By default, Name/_name is a tokenized field so the result you are getting is absolutely valid/expected.


1

It looks like the code that decides if a contact should be indexed is defined in the contacts pipeline in the analytics.aggregation pipeline group. Specifically, the default processor is Sitecore.ContentSearch.Analytics.Aggregators.ContactChangeContactAggregator, which just checks contact.ShouldBeIndexed(), which in turn just checks if it is an anonymous ...


1

This is standard Sitecore behavior. GroupedDroplinkField is a type inheriting from LookupField type. That field's value is only a Sitecore ID of the target item, without any information about language or anything else. Your indexable item may use Thai language, but when you call contentTypeField.TargetItem, Sitecore gets the item in your current context ...


1

What you need to do is: Add reference to Sitecore.ContentSearch.Client in your code Create new class CustomIndexingManagerWizard inheriting from Sitecore.ContentSearch.Client.Forms.IndexingManagerWizard with code: namespace My.Assembly.Namespace { class CustomIndexingManagerWizard : Sitecore.ContentSearch.Client.Forms.IndexingManagerWizard { ...


1

I think in your Sitecore configuration you need to set below two things to as per your requirement(The timezone which you want) of time required and then hope that will resolve this issue. <setting name="ServerTimeZone" value="Value for your timezone"/> <globalization requestEncoding="utf-8" responseEncoding="utf-8" /> Note: Make a patch ...


1

Sitecore OOTB uses two parameters for the crawler Database - Database on which you want to perform the indexing Root - the path of the Sitecore node There is no parameter for the language in it, So OOTB it is not possible. However, you can perform this by creating your custom crawler by inheriting the OOTB crawler. You can do this by adding a new ...


1

You need to review the coveo search config files and make copies of QA index definitions and name them with "DEV_" prefix so you know. Once you define for all databases (master, web, core) you should see these new index definitions in the index manager in sitecore control panel. Select only these indexes (prefix "DEV_") and index them.


1

I've had similar issues to this in the past. Contains() seems to Work in a strange way in Azure Search vs Solr. If I recall it does a regex match on each word. The documentation here is a little confusing: https://doc.sitecore.com/developers/90/platform-administration-and-architecture/en/support-reference-for-azure-search.html What I've seen work is a like ...


1

I have implemented the same functionality with the following code in sitecore 9 update 2 if (sortBy !="date") { string termFreq = GetTermFrequency("suggestiontitle_t", searchText); var query = context.GetQueryable<SearchResultModel>() .Where(i => i.NoIndex == false && (i....


1

If you added a custom core in Solr, take care to include correct conf folder within your core directory. Try copying conf folder from preexisting cores like sitecore_master_index. Once this is done, take care to populate the schema using control panel>Populate the SOLR managed schema option. Once schema is populated successfully, you can try rebuilding the ...


1

For this purpose, I would use the iframe field type, which is IMO the most flexible solution for custom field types. You can find more information about the iframe field type here: Cascading Droplist field in Sitecore https://trnktms.com/2017/04/06/sitecore-iframe-field-basics/ The advantege is that you have the full control of the presentation and stored ...


1

It seems rubber-ducking with the community helped me solve the problem I have had for 3 days. The solution: (it seems you have to do BOTH, although I am not 100% certain) Delete and manually re-create index-catalog Delete all references to the index in the properties table in the core database I believe that the reason why I had the error was partly due ...


Only top voted, non community-wiki answers of a minimum length are eligible