3

First parameter is InstallMode which can be one of 3: Overwrite Merge Skip Second parameter is MergeMode, only valid for Merge InstallMode. Values can be: Merge Append Overwrite It's the same like if you choose options in UI. When you select Merge, you can select another option from the dropdown: I found the image and more information here: https://...


2

There are different approaches you can use but at a basic level you need somewhere for your site files to go (config/admin pages/css/js etc) and then also somewhere for your dlls to go and an nuspec file. The structure we use is as follows: Content - this should be structured in the same way as your Site root folder. e.g /app_config sub folder with other ...


1

The sitecore.aspnet.gettingstarted didn't install SXA to the Sitecore XP0 instance, so I needed to modify the docker files in order to add SPE and SXA to my images. Here is how to do it, if anyone is in the same situation, and need to add a module to their docker-compose file: in .env add the following variables: You'll need mssql to add some databases, ...


1

For CD you can do it manually by following this on the same url https://kb.sitecore.net/articles/406145 -


1

I had the same issue when we have restored Master and Web database from other environments to the environment which I was having issues during generation of Sitecore Support Packages. Basically, I've restored the Master and Web databases from Production to Staging, and I observed the same behavior as you are seeing now, which I believe is some garbage that ...


1

You would need to include the item with the message and all the needed parents. The message item is in the email root (could be /sitecore/content/Email). Within the Messages folder you have folders based on the date (year/month/...). You might want to include those (without all children) to make sure the path to the message item exists. Once you have those ...


1

This reason for this issue is that you have <setting name="Xdb.Enabled" value="true" /> in your Sitecore.Xdb.config. This setting is true by default. When this is set to true, then the ANALYTICS key is read from the connectionstring.config and the interaction with MongoDB starts. If you do not need analytics in your instance then this value can be set ...


Only top voted, non community-wiki answers of a minimum length are eligible