19

You are correct .. none of the old publishing pipelines are called when the new service is installed. Background Traditionally, Sitecore publishes one item at a time. This is inefficient at a larger scale so the Publishing Service, instead, processes items in batches. This means the existing pipelines are no longer conceptually compatible so there ...


18

Turns out that this issue is fairly common. Saw this happen in both SXA and the Publishing Service. The solution is to clear the Temporary Asp.Net files from IIS. Steps: Stop IIS. This can be performed through the UI by selecting the server name in the tree and on the right panel choosing Stop. You can also use the command iisreset /stop from an elevated ...


14

The problem here is with FillDB .. it uses quite a rough-and-ready script to make items, and so it generates items that do not have a unique revision field (it leaves this field blank so it defaults to the Standard Values field - it does this for quite a lot of the standard fields). For the Publishing Service to publish an item it must have a valid revision ...


11

If your content authors are strictly following WorkFlow, use scheduled Incremental publishes. If workflow is not strictly used, use user manual publishes (Smart Publish), and try to cover related item publishes to reduce number of cache clears. For multisite, if you publish item of site-A. It will clear html cache for all sites. It should clear cache for ...


8

By default, the publishing service will publish Blobs if they are created/referenced by the following fields: /sitecore/templates/System/Media/Versioned/File/Media/Blob Guid = {DBBE7D99-1388-4357-BB34-AD71EDF18ED3} /sitecore/templates/System/Media/Unversioned/File/Media/Blob Guid = {40E50ED9-BA07-4702-992E-A912738D32DC} In case of you defined your own ...


8

TL;DR You can ignore the errors as long as you make sure you publish the installed items with a Full or Single Item publish. The details We have tested this and confirmed this as platform bug in 8.2 (rev 160729), when a package is installed the SaveItem event is not passed a language. This doesn't effect how Sitecore saves the item data itself, but the ...


6

Assuming you have correctly configured Sitecore Publishing Service (I have not) you should raise support bug for that. Here is what I have found: Whenever you try to install an item with Overwrite option the installation will fail. Doesn't matter what package and what is inside. You can check this by creating a new package with Sitecore standard item and ...


6

I agree with comment from Yogesh about publishing following the business use case. I usually consider workflow based publishing(autopublish on approval)/manual publishing (assuming you meant adhoc publish and not person initiating publish daily at 9pm :p) to be both adhoc as there is less control on the time of publish. As we are all well aware of the ...


6

This is by design. For performance reasons, the Publishing Service only reports field changes that are essential for features in Sitecore to function correctly. The fields that will be reported on are: Revision - {8CDC337E-A112-42FB-BBB4-4143751E123F} NeverPublish - {9135200A-5626-4DD8-AB9D-D665B8C11748} PublishDate - {86FE4F77-4D9A-4EC3-9ED9-263D03BD1965}...


5

In case sestocker answer is not the problem you are having: You need also to make sure you have setup properly the instance properties(if you don't know what this is reffer to Sitecore's scaling guide). This is really important to enable Sitecore to clear the cache properly after the content is published from the content management server into the content ...


5

I have put together a config from the info on this good answer for Sitecore 8. Have a try at applying the following config on both CD and CM: <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/"> <sitecore> <settings> <!-- This setting is changed from the default value to enable parallel processing of publishing ...


5

The Publishing Service is not yet available on Azure PaaS. It was announced at the symposium to become available for Azure PaaS with Sitecore 9.1 release.


5

.Net Core has turned configuration on its head for the better IMO, have a read of this it explains how it works. The bad news is that encrypting secrets may not be possible as they are handled differently as per this doco. In a project, I am currently working on, a pure ASP.Net Core website, we ended up creating our own secrets provider. The unfortunate ...


4

According to the release notes, "The schema tools are now part of the Publishing Service." Therefore the command should now be: Sitecore.Framework.Publishing.Host schema upgrade This is also covered in the installation guide for Sitecore Publishing Service 2.0. The guide was recently updated (yesterday in fact), so maybe there were errors in earlier ...


4

As Stephen pointed out, it's a shortcoming of the Fill Db tool. We're hoping to get a fix for this out in the next Sitecore release (but no promises). In the meantime, you can use the following SQL script to 'repair' your Items. The first script will report any Item versions that don't have a revision field. The second script will create a revision ...


4

I had the same issue, and it was because I turned on the Debug mode in Experience Explorer, and then I just closed the tab without changing back to Edit mode. After I opened Experience Explorer in Edit mode, the list of Languages was visible, and Publishing started working fine for me.


4

You should set the publish date for the latest version. You need to make use of the Versions tab to be able to set which version to be published and when. Please see screenshot below Example Let say you have 2 versions on the item. Version 2 contains the updated data. So, you need to set this version to be published at your defined date/time.


4

Try to execute first Sitecore.Framework.Publishing.Host schema downgrade –-force and then execute Sitecore.Framework.Publishing.Host schema upgrade –-force For me worked well few times.


3

Maintaining the descendants table is supported by the Publishing Service, it's just not enabled by default, and not documented. It's not enabled by default because it adds a performance cost to each publish, which scales with the size of the content tree, regardless of the size of the publish job. It's only required by the 'fast query' API, which is no ...


3

This is quite a lot of questions all at once but I'll try and answer as best I can. I'm not sure if your using version 1 or 2 of the publishing service but you should find that since these are two targets then two manifests are created (one for web1 and one for web2). However for performance the new publishing service will execute publishing in batches ...


3

We’ve used this module to great effect before and it is much more feature rich than the out of the box auto publishing task: https://marketplace.sitecore.net/Modules/S/Sitecore_Scheduled_Publish.aspx?sc_lang=en It’s by the Hedgehog Guys, it’s also on GitHub here with docs: https://github.com/HedgehogDevelopment/SCScheduledPublishing I’ve not tried it ...


3

Edit 14/6/17: This has indeed been fixed in v2.0 Update 1 (release notes) The error message you are seeing is indeed the cause of the Publish Service ceasing to function. Basically, the Service is configured to always assume it's running in a multi-instance setup. On a repeating interval, it will try to obtain an 'activation lock', i.e. it will try and ...


3

Sitecore.Publishing.PublishManager is recommended to use with SPS instead of Publisher. It will show also all publishing tasks in the Publishing Dashboard of SPS.


3

It looks like you have a custom publishing target (public) that you are trying to publish to. First thing I would check is the casing of public. From the sparse logs you provided, it looks like there is a Public target configured but you may want to update your publishing target name in Sitecore to be Public instead of public as a first step. You will want ...


3

It ended up with the Permission issue with SQL User defined per database in connection string. It need to be SQL admin user not the database user which are created during installation. To run the Upgrade or Downgrade command, please make sure the sc.publishing.xml is using the SQL Admin credentials. Once commands are successfully executed, you can switch ...


3

We found a solution that worked - clear dbo.Publishing_JobQueue table in master database: delete from [mywebsite_Master].[dbo].[Publishing_JobQueue] It is very strange, besause of all records in this database look fine: After deleting this data, Publishing Dashboard starts to work as expected: tables on the page are populated with new publishing jobs ...


3

This is a confirmed issue in Publishing Module 9.3. Ticket number 381220. Fixed in 10.0 ​​The OperationCompleteTimestamp is set to null during a publishing job and this causes a nullable exception on the Sitecore side and empty data in the dashboard​.


2

If you upgraded from 1.1, try Clearing your browser cache, we rewrote all SPEAK dialog in 2.0. Looks like SPEAK isn't databinding to our new JSON changes.


2

This was resolved by adding the following config file to the App_Config\Include folder: Sitecore.Speak.Components.config. It was missing in my include folder.


2

As the publishing service should have an open api, you should be able to send requests to it (maybe Stephen Pope can elaborate on that). I'm not sure how to do that, but if you only need that publish to update your index you might be able to get what you need by using the IndexCustodian. That class has functions to rebuild your entire index, or parts of it....


Only top voted, non community-wiki answers of a minimum length are eligible