Hot answers tagged

7

If it is Sitecore only you are installing, you just need to change the setup.exe.config. Open the setup.exe.config and add this parameter to the XPSingle template (if that is what you are installing): <template name="XPSingle" path=".\XP0-SingleDeveloper.json"> ... <parameter name="SitePhysicalRoot" value="[your-path]" /> </template> ...


3

Looks like two things tripped me up: Not having the right version of SQL server (2017 minimum) Something went wrong with the creation of the solr service using the installer - even though it looked like it had installed/was running ok. Manually setting up the service and referencing that in the installer worked like a charm. For anyone needing a reminder ...


2

The basic difference is Setup.exe is being used by Sitecore install assistant (GUI for easy Sitecore setup) whereas XP0-SingleDeveloper.ps1 is used by Sitecore Install Framework (Developer friendly method using PowerShell to install Sitecore). You need to update the files according to your choice of installation method.


1

You dont need to disable lucene indexes as this can be done from web config search app setting. This might come from one of your custom index configurations, try to remove the custom solr index configs one by one and see which one is causing the issue. Possible issues: One of your custom indexes uses a solr core that is not yet created locally. You might ...


Only top voted, non community-wiki answers of a minimum length are eligible