3

So basically my Sitecore XConnect Search Indexer can't start. When looking on its own logs, I found this exception stack trace: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Sitecore.Nexus.Licensing.LicenseException: Required license is missing: Sitecore.xDB.Base at .(‬‮‍‎‍​‭‎‮...


3

Apparently the SitePhysicalPath is transferred en used in all of Sitecore jsons, but not in the one from SXA. Quick fix: open SXA-XP0.json and find the Site.PhysicalPath variable (line 69). Adjust it to the path you installed the site, something like: "Site.PhysicalPath": "[joinpath(environment('SystemDrive'), '...', '...', 'wwwroot', parameter('SiteName')...


1

Sometimes, if you have tried the installation script more than once, you can have some undesired behavior. Like some said before, you are possibly trying to go forward with the wrong certificates. Also, some of these services were actually created on previous installation attempts. Here is what I think should help you get through. Clean your workspace ...


1

Looking at Solr-SingleDeveloper.json. There is a parameter named TempLocation: "TempLocation": { "Type": "String", "Description": "Alternative location to save downloads. If left on the default $Env:Temp will be used.", "DefaultValue": "SIF-Default", "...


1

Try specifying the value of the Install Path to some other drive other than C drive in the Install Solr step while running the Sitecore Installation Assistant. Some paths in C Drive may cause permission issues unless you have granted access in the folder's properties in file explorer.


1

Can you try logging into the SQL Server with the entered credentials in SIA. Once logged in, check the SQL Server Instance name. Most probably, it's not (local)\SQLExpress. It might be a computer name


1

You could have a look at these below options for your new CM2 instance. 1) Please check the self-signed certificate has been installed in your new server. The SOLR instance is running up with the https certificate. 2) Your xconnect website https://xp0.xconnect/ should be running up with self signed https certificate. 3) Sometimes also seen that the ...


1

Solr service URL is specified wrongly. Based on error log where you have duplicated "//" in the path, I assume you have specified your Solr service URL like this https://solr75:8750/solr/. Correct value is without / at the end. Change your Solr service URL to this value instead https://solr75:8750/solr


Only top voted, non community-wiki answers of a minimum length are eligible