Questions tagged [sxa]

Anything related to the Sitecore Experience Accelerator (SXA)

Filter by
Sorted by
Tagged with
0
votes
1answer
23 views

How do I change http cache control options when a page contains personalized components?

I am using Sitecore 9.3, sxa. I want to change the Http Header cache-control to no-store when an page or item on that page has been personalized. How do I go about doing this? Any articles/blogs or ...
0
votes
0answers
23 views

Reading CSS and JS from filesystem from assets folder in webroot [closed]

When viewing page is preview mode css and js working fine but when directly viewing the url css and js not loading . On viewing page source and clicking on link of js it's showing not found.
0
votes
0answers
16 views

SXA Extending Component Search URL

Working on Sitecore 9.3. What I'm trying to do is edit a base .js file, being component-search-url.js. Specifically, I want to update the setEndpoint function to always return the endpoint. Currently ...
0
votes
0answers
54 views

SXA Search is unable to return result with '/' and/or '&' in Facet value

I have a sxa search component with multiple facets. In one of the facets, there is an entry that has a filter value of "Corporate / M & A". It yield no result when I choose the facet ...
0
votes
1answer
20 views

Custom Bucketing structure is never being hit

I have created a new Rule action on which to create a bucketing structure which takes in a selected date field and build the structure off of that date field. However, this rule is never hit. I have ...
0
votes
0answers
29 views

Exact search in Azure search in Sitecore SXA

Using azure search in Sitecore SXA 1.7 and it is not fetching exact result likewise if we are using "Test data" in search box then it is showing result based which match "Test data ...
0
votes
0answers
29 views

How to hide rendering component in Experience Editor in Sitecore SXA?

I have a page with 3 datasource rendering. 1st datasource rendering has 3 number version, 2nd datasource rendering has 2 number version, 3rd datasource rendering has 1 number version I am hiding 3rd ...
0
votes
1answer
43 views

Null checks in Scriban

I want to check for null values in Scriban. {{ if (o_model.address.id) }} <div style="text-align: center;"><h5>Address {{ o_model.address.id}}</h5><br /></div> ...
0
votes
0answers
26 views

Can we create multiple ActionResults in Sitecore SXA custom controller rendering?

Per Sitecore SXA 9.3 documentation, in SXA custom controller, we have to override the GetModel() method and we call repository to get the model. I would like to create multiple Action Results (...
1
vote
1answer
45 views

Making config settings configurable for user

I am using Sitecore 9.3, SXA. I want to make some of the current config settings configurable from within Sitecore. I have created a template with all of the fields (e.g. MediaResponse single text ...
0
votes
0answers
19 views

Clone SXA Carousel; Unable to change the Carousel Slide Item rendering variant

I'm working to create a clone of the Carousel Composite component. I've been able to update the Datasource and Rendering parameter templates for my use cases. However, I'm unable to change the ...
0
votes
0answers
7 views

Login with social media account [duplicate]

how can I allow users to login through their social media accounts ?!! as I am using sitecore 9.3.
0
votes
1answer
34 views

Unable to export query result to a file from Sitecore Powershell scirpt with Out-Download command

I have a simple powershell script which uses Out-Download command to export the query result to .xlsx file. However, it doesn't seem working. The same scenario as well if I used the download button ...
-1
votes
0answers
28 views

Any command or pipeline run when selecting any version from Experience Editor [duplicate]

Is there any command and pipeline run when we select any version from Experience Editor in Sitecore SXA ?
2
votes
1answer
49 views

Using Model in Scriban template

Is it possible to use the current Model in Scriban? I have a CutomHeroViewModel public class CustomHeroViewModel : VariantsRenderingModel { public string HeroTitle { get; set; } public string ...
0
votes
1answer
39 views

Using List<string> in SXA rendering variant

I have a CustomHeroViewModel class public class CustomHeroViewModel : VariantsRenderingModel { public string HeroTitle { get; set; } public string HeroDescription { get; set; } public List&...
1
vote
1answer
47 views

Use SXA rendering variant for dynamic object

In my Sitecore 8.2. I have a rendering that has a Multilist called Fields. This Multilist is pointing to the Fields folder in Sitecore. In the Fields folder, the content editor can create a new item. ...
0
votes
0answers
25 views

Sitecore SXA optimized files not created

I am using sitecore 9.3 with SXA, i enabled optimizer globally and for the page designs but the optimized file is not created for each theme under "BaseThemes". Optimization enabled as per ...
0
votes
1answer
25 views

Css not reflecting in sitecore modal window

I am opening a modal window using <a href="@Url.Action("SearchModal", "Myctrler",new { id =itemVal })" onclick="window.open('@...
0
votes
0answers
68 views

Search checklist field data in the Content search API in Sitecore SXA

I would like to search checklist data through the Content search API in the Sitecore SXA. However, it is not searching any data based on checked value in checklist field. Sharing code : Template: Name ...
0
votes
1answer
33 views

How to render datasource version after page load through programming in Sitecore SXA?

How can we render datasource version of the page through programming in Sitecore SXA ? Based on page version we want to render datasource item version on a page in experience editor.
3
votes
0answers
349 views

SXA Video, Youtube doesn't show thumbnail on mobile?

I am using a Video component and I've created a couple examples, 1 video uses a YouTube source, the other uses a video in the media library. On mobile devices, the Youtube video doesn't show the ...
2
votes
0answers
49 views

Sitecore SXA override Search Controller

I am using Sitecore 9.3 with SXA search components (search box, search results, filters and paging) and needs to extend this to read data from custom API. What I have thought of is to clone the search ...
0
votes
3answers
55 views

How to check request id is a page id or datasource id in code in Sitecore?

I want to check requested item id is a page item id or datasource item id through code. For more clarity, I have a scenario in SXA where we need to check requested id is page id or datasource id. If ...
0
votes
0answers
24 views

Open graph URL does not contain language

I'm using Sitecore 9.1 and SXA 1.8, I want to embed the language in the og:url meta tag, I've checked the configuration of the LinkManager, languageEmbedding is set to true, but still it's not ...
1
vote
1answer
24 views

Redirect home item not working with SxA

We are using SXA 1.9 and I can reproduce the behaviour on a vanilla sitecore instance with SXA 1.9 installed. I've created a tenant called "my-tenant and" a site called "my-site" ...
0
votes
1answer
43 views

Error while rendering view: '/Views/SxaLayout/SxaLayout.cshtml' on CD but not on CM

I'm using sitecore 9.1.1 and SXA 1.8.1. I have a scaled environment. I have multiple sites: one shared site where I have my rendering variants, and another two sites. I'm using query in the rendering ...
0
votes
0answers
15 views

SXA Unrecognized Guid format on certain URL path

Our site has language embedding enabled, so our site URL is https://{siteUrl}/en But when I mistakenly omitted en and typed a path (which is a two-letter word, e.g. https://{siteUrl}/gg it throws the ...
0
votes
1answer
59 views

Removing datasource version of the page when we remove page version in Sitecore 9.1.1

I have added datasource version of the page through programming. When I am adding any version of the page then it will automatically add version for the datasource items in Sitecore 9.1.1. Queries : ...
0
votes
0answers
32 views

Components do not save in specific dynamic placeholder

We are using sitecore 8.2 and recently added SXA sites. The existing site has a dynamic placeholder setting section-content*, which stopped working after we added SXA sites. When I looked for "...
0
votes
1answer
33 views

Model.VariantFields return null when creating custom SXA rendering with variants

I created custom SXA rendering with variants but Model.VariantFields return null. my controller public class NotificationController : VariantsController { protected NotificationRepo ...
0
votes
0answers
19 views

Testing in partial designs

We are trying to create a test inside of a partial design to see if it is possible. We can add the tests without issues. But after I push save, all the datasources turn to an empty Guid.
1
vote
0answers
20 views

How to disable the animation of SXA image gallery in mobile

I have added the Sitecore sxa image gallery. My requirement is to hide the pop up which comes in the mobile view on double-tap of image. I have tried with event.preventdefault ,.stop(),event....
0
votes
2answers
24 views

Updated field in rendering variant not working

The requirement was to show the last updated date and time of the item in the page. So I tried to create a rendering variant of page content with field as Updated (which is there for every item ...
1
vote
0answers
23 views

cannot add version to item null exception when adding contact to a list

I am trying to create a list using a CSV file, but somehow, I cannot do so because of the underlying issue. I understand that he is trying to create an item and a version, why does it fail? How can I ...
0
votes
1answer
30 views

Json Reference field in Json Variant return Error when the Reference Field Is empty

I am using SXA Json Content to create API. In the JSON Variant, I used Reference Field to display Drop Link Field in the data. But when the DropLink field is empty, the API returns error. So I need to ...
0
votes
0answers
24 views

SXA Filter API ignore the custom index

I'm using Sitecore 9.1 and SXA 1.8, I've created custom index for my site and it's working fine, the SXA OOB Search results API is using the custom index which is right But the SXA OOB Search filters ...
0
votes
1answer
31 views

Sitecore SxA Composite Layout not adding custom css and js

We have created a custom Accordion Module. Therefore, we also changed the Accordion MVC Layout.cshtml for Accordion Items. But our custom theme doesn't appear in the head nor does the js show up. What ...
0
votes
0answers
18 views

JSON Layout outputting json content inside a div

Using a Sitecore 9.1.1 site with SXA 1.8.1 - I added a new page and changed the Layout via Presentation Details to use the JSON Layout option. I was then able to open in experience editor and see the ...
1
vote
1answer
31 views

Use site specific search indexes configured on SXA site item in Content Search API

When making Content Search API calls, Sitecore resolves the index based on certain logic which is very well explained here. In SXA, we do have an option to configure the indexes on the site item, ...
0
votes
0answers
66 views

Getting exception for Sitecore custom API calls

I'm working on an SXA Project with to different code base one with SXA Commerce and other with SXA without commerce integration. The commerce site is gone to production before 4 months and we started ...
0
votes
1answer
80 views

Editing JSS SXA route fields in Experience Editor

Using a JSS site deployed on SXA 9.3, is it possible to edit route fields in Experience Editor ? I have assigned simple fields to the route template and in Experience Editor I have tried using the ...
1
vote
3answers
56 views

SXA Navigation Component Set start node to the current page

I am using sitecore 9.3 with SXA, i want to know if there is a way to set the start node of the navigation component to the current page so that it can render the navigation dynamically instead of ...
0
votes
0answers
30 views

SXA Theme doesn't load with Snippet in Experience Editor

I am using SXA 9.1.1 I have created a theme and it works fine with my pages. But when I go to Data-> Snippets and open a snippet in Experience Editor, then my theme doesn't load. Maybe it loads the ...
0
votes
2answers
39 views

301 Redirects for Non SXA site in a Sitecore SXA instance

I have a Sitecore instance with both SXA and Non SXA sites. I want to implement 301 redirects for both the sites. For the SXA site, I'm able to do it through the SXA Redirect Map but how do I perform ...
1
vote
1answer
26 views

Custom variant component is not showing component variant selection in Experience Editor

I created a custom variant component following this guide. I couldn't find the "Component Variant" selection of my custom variant component in Experience Editor. Is there any additional ...
4
votes
1answer
44 views

What is the use of empty partial design, which comes by default in SXA

Whenever we create a new site in SXA, by default there is an Empty partial design gets created and there are no components added to it. What is the actual purpose of empty partial design? can we ...
0
votes
0answers
53 views

Is there a way to access all of a page's components?

I want to create a custom scriban Processor and I need to access all of the renderings that have been put on the page. Is there a way to access that data?
0
votes
0answers
33 views

Add extra columns to the customer entity

We recently migrating our current sitecore site to SXA with commerce. I have a user registration/login feature in the site. I want to extend the customer entity (Commerceuser) with some additional ...
0
votes
1answer
27 views

Missing exception - Sitecore.XA.Foundation.Abstractions.Services.IContentTestingService.GetMultivariateTestDatasource

I was extending Sitecore CopyGlobalDatasource functionality. It was working fine, but recently I can see issue while browsing any page through the Experience Editor. Seems like missing method or ...

1
2 3 4 5
18