Keith VanderVeen
  • Member for 5 years, 4 months
  • Last seen more than 1 year ago
  • GitHub
  • Colorado Springs, CO, United States
What's the best migration strategy for 6.5 to 8.2?
23 votes

When I did an upgrade from 7.2 to 8.1 earlier this year, I followed these steps: Setup a new instance of Sitecore 8.1 and configure it according to the documentation. Get my settings/layouts into ...

View answer
An item name lenght should be less or equal to 100 while installing a content package
6 votes

In Sitecore.config file, you need to find this item: <!-- MAX ITEM NAME Specifies the maximum length of an item name. Default value: 100 --> <setting name="...

View answer
Google Analytics vs Sitecore Interactions
Accepted answer
5 votes

OK, so I've spoken with Sitecore support about this issue, and they were able to help me come up with the answer. The reason for the difference is because of the way that I was counting the ...

View answer
How do you setup a 404 and 500 error page for missing files and media items?
4 votes

The basic idea is that you need to create 2 different pipelines so that you can "catch" the bad page, and then after Sitecore has rendered your custom error page, you need to tell Sitecore to return a ...

View answer
When rebuilding the reporting database stuck on StoppingDataRecording
4 votes

According to the Official Sitecore Documentation, there is a note that reads You can only run the RebuildReportingDB.aspx and RedeployMarketingData.aspx pages from a content management server. ...

View answer
How do I get the map component to work in SXA?
Accepted answer
4 votes

The first thing that you need to do is to go into the Maps Provider for your website. You can find that under the Settings node in the Content Editor. When you click on the Maps Provider node, you ...

View answer
SOLR Cloud error "The remote server returned an error: (500)"
Accepted answer
3 votes

I ended up attacking this from the solr side. In the solrconfig.xml I added an invariant to rows and after a rebuild the site is working as expected. It looks like this: <requestHandler name="/...

View answer
How to figure out why I have a sudden spike in traffic between CM and CD servers
3 votes

Thank you everyone for your help! Here's what my process ended up looking like. I hope that it will help others: I checked the Sitecore Search log, and found that I was getting the same query running ...

View answer
How to request a specific variation of an A/B or Multivariate testing?
3 votes

The information of which variation a particular visitor got should be stored in the Interactions Collection of your Analytics Mongo DB. You can look at a particular Interaction and look at the Pages ...

View answer
WFFM Selecting a List Item doesn't work
2 votes

I got a response back from Sitecore support on this issue, and apparently this is a known bug for the particular version of Sitecore and WFFM that I'm using. So if you encounter this, ask Sitecore ...

View answer
Experience Editor returning lots of JS Errors when running in Docker
2 votes

So I ended up rebuilding my docker image, this time not using the volumes capability on the docker-compose.yml file. So my file now looks like this: version: "2.1" services: mongodb: image: ...

View answer
Why is my Experience Analytics dashboard blank in Sitecore 8.1 Update-3?
2 votes

There are several reasons why it could be blank: You just installed the Site, and the agent that aggregates the data has not run yet (it only runs 1 time per day, and does not include the current day'...

View answer
Analytics Database manager not compatible with Sitecore 8.2 Update 7
Accepted answer
1 votes

I submitted a Sitecore Support ticket, and they provided a DLL for me that is a supported fix for this issue. So, if you encounter this issue, all you have to do is let Sitecore know that you need the ...

View answer
404 errors in Experience Profile after upgrading to 8.2
Accepted answer
1 votes

So after spending quite a bit of time double-checking my configs (and opening up a Sitecore Support Ticket), I found out that there were 3 things that had messed me up. Hopefully, one of these things ...

View answer
A public action method 'Summary' was not found on controller 'myControllerName'
1 votes

So after much research, and pouring over my code, I realized that I had a compilation error that happened when I had merged my branch from the master branch in our source code repository. What that ...

View answer
SXA Creative Exchange Error: Could not find any storage definition in your site. Export cannot be performed
0 votes

OK, so we were finally able to figure out how to solve the problem: We had to upgrade our SXA install to use 1.3 Update 1. We hadn't touched this project for a few months, and decided to go ahead and ...

View answer
Analytics Tracker Config: What is the Proper Configuration for Multisite?
0 votes

The Tracker.current is not initialized is a generic error and does not necessarily mean that there is something wrong with your tracker configuration. In my experience, it means that the problem ...

View answer