1

Using Sitecore 10.1.2

Whenever I deploy a custom DLL into my local instance, the first page load takes more than 30 mins.
It could be any DLL. I publish them in debug mode and there are no *.pdb files.
I do not see any errors in the log.

How should I go about troubleshooting this or is there any way to improve the page load speed.

1
  • 2
    Try running DELETE FROM [EventQueue] on both core, master and web databases.
    – Marek Musielak
    Jan 18, 2023 at 9:13

2 Answers 2

2

A few things you can try out to speed up local instances are as followed.

  1. Add optimizeCompilations=”true” to the compilation tag in web.config.
<compilation defaultLanguage="c#" debug="false" targetFramework="4.6.2”>

With

<compilation defaultLanguage="c#" debug="false" targetFramework="4.6.2" optimizeCompilations="true">
  1. In Sitecore.Xdb.config located in \App_Config\Sitecore\Marketing.xDB turn off tracking and analytics by setting Xdb.Enabled and Xdb.Tracking.Enabled to false
  2. Turn off device detection in \App_Config\Sitecore\DeviceDetection.Client\Sitecore.CES.DeviceDetection.config by setting DeviceDetection.Enabled to false
  3. Patch the configuration to make sure the agent doesn’t run every 10 seconds. It appears to be related to list management.
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:role="http://www.sitecore.net/xmlconfig/role/">
 <sitecore role:require="Standalone or ContentManagement">
 <scheduling>
 <agent type="Sitecore.ListManagement.Operations.UpdateListOperationsAgent, Sitecore.ListManagement">
 <patch:attribute name="interval">00:30:00</patch:attribute>
 </agent>
 </scheduling>
 </sitecore>
</configuration>

refer this for more details: https://www.symsoftsolutions.com/sitecore/tips-to-make-sitecore-load-faster-on-development-machines/

hope it helps!

1

You can try the following things along with the steps given in the answer:-

  1. If you want to make your compilation more selective you can also set batch to false value.

    <compilation defaultLanguage="c#" debug="false" targetFramework="4.5"  optimizeCompilations="true" batch="false" >
    
  2. You can also consider to use RAMDisk for your compilation temporary files.

    <compilation defaultLanguage="c#" debug="false" targetFramework="4.5"  optimizeCompilations="true" batch="false" tempDirectory="X:\TEMP\">
    
  3. You should update file machine.config and set in node /configuration/runtime following value.

    <generatePublisherEvidence enabled="false"/>
    
  4. Sitecore Performance Counters. Counters store an information about number of different activities. They can be very useful but if you at particular moment do not need them, you can just turn off them.

    <setting name="Counters.Enabled" value="false" />
    

Read more details:-

http://sitecore.skowronski.it/sitecore/speed-up-sitecore-instance/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.