3

I am able to access a page using the path:

https://<<My Domain>>/Sitecore/content/page_path

This has been crawled by Google, I don't want these URL's to be accessible.

I would like to know what is the correct way to handle these? Should this be resolved and URL be changed? or should we be blocking the requests for anything containing Sitecore/Content in request URL?

My Site definition is:

database="web" domain="extranet" disableClientData="false" cacheHtml="true" htmlCacheSize="250MB" cacheRenderingParameters="true" renderingParametersCacheSize="100MB" allowDebug="true" enablePreview="true" enableWebEdit="true" enableDebugger="true" enableAnalytics="true" notFoundItem="/sitecore/content/ZZZ/ZZZX/Home/Error"/>

Thanks,

Samridhi

5
  • I think that your site is not configured correctly. Can you add definition of your site into your question? Follow this doc doc.sitecore.com/developers/90/… and put into your question everything which is between <sites> and </sites> xml elements which should look like this sdn.sitecore.net/Articles/Administration/… Jan 24 '19 at 4:55
  • My Site definition is : <site patch:before="*[@name='website']" name="XYZ" physicalFolder="/ABC" virtualFolder="ABC" rootPath="/sitecore/content/ZZZ/ZZZX" contentStartItem="/sitecore/content/ZZZ/ZZZX/Home" startItem="/Home" language="en" contentLanguage="en" Jan 24 '19 at 5:48
  • database="web" domain="extranet" disableClientData="false" cacheHtml="true" htmlCacheSize="250MB" cacheRenderingParameters="true" renderingParametersCacheSize="100MB" allowDebug="true" enablePreview="true" enableWebEdit="true" enableDebugger="true" enableAnalytics="true" notFoundItem="/sitecore/content/ZZZ/ZZZX/Home/Error"/> Jan 24 '19 at 5:48
  • 1
    @samridhisachdeva can you add the entire <sites> block from your /sitecore/admin/showconfig.aspx to the question (not in a comment)? That will help others who are trying to help you. Jan 24 '19 at 12:58
  • Hi @samridhisachdeva have you found solution of this? i have the same problem. Thanks
    – Vsn
    May 5 at 1:55
5

You need to block them. Ideally, Google should never have been told about these URLs in the first place, it looks like you might have some mismanaged Site Url Generation going on elsewhere.

But for purposes of getting these links OFF Google again, you need to block them. Easiest way to do it, is to use a Rewrite rule. Something like:

<rule name="sitecore predixes" stopProcessing="true">
    <match url="^sitecore/?(.*)" />
    <action type="Redirect" url="http://www.hostname.com/{R:1}" />
</rule>

(you need to create a proper match url, to filter out /sitecore/content)

Then enable this rewrite rule on IIS and tell Google to reindex.

Secondly; you need to ensure that all the URLs you generate for your site are correct. Here is a good resource to help you get started: Safely Defining Multiple Sites in Sitecore

0

Following the best SEO practises would be the best.

  1. Implement canonical URL on all pages
  2. Consider using Robots.txt
  3. Make sure your XML Sitemap is correct
  4. Maybe using a 301 Redirect to strip out the /sitecore/Content/ part of the URL
5
  • You are trying to find solution for the current situation not the root cause of the problem. Redirection will not help here. This must be a problem of misconfiguration of site in Sitecore Jan 24 '19 at 5:01
  • ya I don't want to go with redirects option, also I don't have the Robots.txt in my website. Jan 24 '19 at 5:49
  • 2
    There is no misconfiguration though. Since Sitecore 5, it has been possible to use hostname/sitecore/content/home to reach the home node. It's by design.
    – Mark Cassidy
    Jan 24 '19 at 9:48
  • so what's the way to restrict these URLs on public site ? Jan 24 '19 at 9:54
  • If you must, override the item resolver in the pipeline. I will not recommend this approach however as I'm sure by doing so, something else will be broken. Hence my original answer. Jan 24 '19 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.