0

Trying to install a package which has the item names with characters like (', '.', ').

How can I temporarily disable ItemNameValidation setting? Tried changing the setting to '.*' which did not help.

Sitecore version - 9.1.1

2

There are 2 settings that control item names during package installation:

InvalidItemNameChars should be blank.

ItemNameValidation should be .*

With this settings you should be able to install package with any item names.

2

Try the following patch:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <settings>    
      <setting name="ItemNameValidation">
        <patch:attribute name="value">^.*$</patch:attribute>
      </setting>
   </settings>
  </sitecore>
</configuration>

The regex means that:

^ start of the string

.* It matches any character.

* Quantifier — Matches between zero and unlimited times, as many times as possible.

$ End of the string

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.