1

I'm using the Integrated Dynamic Placeholders v1.2 and see the following 2 issues. Not sure if they are related.

  1. In experience editor when I add 2 column 6-6 component, it shows the placeholder only for col-wide-1. It's not showing the placeholder for col-wide-2. [I gave them colored borders to identify.]

enter image description here

  1. I have added the components via content editor. And when I check the page in Experience editor, it has added another 2 column 6-6 on its own.

enter image description here

enter image description here

Section Centered.cshtml

<section class="aboutUs">
    <div class="container">
        @Html.Sitecore().DynamicPlaceholder("section-centered")
    </div>
</section>

2 column 6-6.cshtml

<div class="row">
    <div class="col-lg-6 col-md-6 col-sm-6" style="border:1px solid red;">
        @Html.Sitecore().DynamicPlaceholder("col-wide-1")
    </div>
    <div class="col-lg-6 col-md-6 col-sm-6" style="border:1px solid green;">
        @Html.Sitecore().DynamicPlaceholder("col-wide-2")
    </div>
</div>

Am I missing any setting here. Using Sitecore 8.2 with MVC

2

1) For the col-wide-2, make sure the Editable checkbox is checked on the placeholder settings.

enter image description here

2) Have you perhaps added the 2-column-6-6 on the standard values of your template and then added it again through the page editor?

  • Thank you Koen. I did not add the placeholder col-wide-2. Any more thoughts on the 2nd issue. It is not a standard value, I checked. – Qwerty Jan 23 '17 at 11:04
  • 1
    Can you check the Shared and the Final layout? – Koen Heye Jan 23 '17 at 11:20
  • Yes, the Final Layout had a different set of components. This never happened before. I removed all and added the reqd. set and it worked. Why did this happen. I always worked on only shared layout and the same would reflect for Final layout too. – Qwerty Jan 23 '17 at 11:37
  • @Qwerty When editing through Experience Editor, the default is the Final Layout. This means anything added through EE will go directly to Final Layout and skip Shared Layout, unless you specify you want to add to Shared Layout. Try looking at the Presentation Tab and changing the Layout selected. – Xalor90 Jul 11 '18 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.