I deleted an item located at /sitecore/content/foo/bar with several subitems from Sitecore and restored it back from Recycle Bin immediately.

Now I'm able to see all the subitems if I run a query in XPath Builder like this: fast:/sitecore/content/foo/bar/*, but nothing if it's like this: fast:/sitecore/content/foo/bar//*. The exact same query (with //*) works at an another server where the same application is deployed but nothing was deleted&restored.

If I run fast:/sitecore/content/foo//* I get everything foo contains except for bar and its subitems.

In attempt to troubleshoot I tried restarting the iis application pool, sql service and pretty much everything I could lay my hands at in case something got cashed. Would really appreciate a bit of advice on handling this. Thanks!

1 Answer 1

  1. Open Sitecore.config and increase the DefaultSQLTimeout setting to 2 hours (just in case).
  2. Go to the Control Panel and run the "Clean up Databases" application for the Master and Web databases. Don't close the dialog until the cleanup is done.

The issue should be fixed after that.

I am fairly confident it is the "RebuildDescendants" part of the cleanup that fixes the issue by rebuilding child-parent relationships between items.

A similar problem is described here:


  • Thank you so much! It worked. And what do you think was triggering this behavior? I checked this question: sitecore.stackexchange.com/questions/3419/… to understand what exactly was done and couldn't understand for sure what in the list of actions has remedied the situation.
    – Elena P
    Mar 23, 2017 at 14:56
  • 1
    @elellle I had this happen to me before, and "Clean up Databases" always helped. I am pretty sure it's the "RebuildDescendants" task that fixes child-parent relationships in such cases. Mar 23, 2017 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.