0

I have installed JSS tech preview 4 and trying to import the sample react app "sitecore-embedded-jss-app".

When running jss deploy app or jss deploy app -c -d , I get the message

Forbidden - Access is denied. You do not have permission to view this directory or page using the credentials that you supplied. 

I assume the credentials that are used are that of user "sitecore/jssimport"

Is that a correct assumption? Elevating the rights for this user in Sitecore still has same result. Setting full control rights for everyone to filesystem has same result.

Any ideas what causes this error?

1

A few troubleshooting suggestions:

  • Have you deployed the app config for the sample app? jss deploy config
  • Have you installed the JSS server package on your Sitecore instance? http://jss.sitecore.net/docs/getting-started/jss-server-install
  • Are you able to browse without 403 error to the host name of the deployUrl value defined in scjssconfig.json? e.g. http://jssreactweb. Ensure that your app config has been deployed and host name has been bound to your Sitecore IIS site.
  • Do you have a deploySecret value defined in your scjssconfig.json and a [appname].deploysecret.config file in /sitecore/config? Run jss setup if not.
| improve this answer | |
1

The problem was caused bij a set of rules in the web.config of the sitecore site stating that all traffic should be redirected to https. setting in scjssconfig was pointing to http://my-app. Disabling the rules in the web.config stopped the problem from occurring. Thanx Adam for pointing me in the right direction.

| improve this answer | |
0

I had also faced similar situation , in my case following 3 points needed to be changed :

1) Make sure your Sitecore License has JSS license included , you can check this from licenses

enter image description here enter image description here

2) Make sure you have installed the JSS Server Components Sitecore package through installation wizard as per your Sitecore instance version from following link. https://dev.sitecore.net/Downloads/Sitecore_JavaScript_Services.aspx

3) Make sure that when JSS setup command is executed and you are prompted to provide option, provide the app name of your JSS app in Sitecore hostname , similarly Sitecore Service URL as shown below. Of course new IIS site binding and host entry is also required.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.