I'm trying to create new contacts (in SC 9.0.1) via DEF 2.0.1.

I'm reading the data from the Azure Service Bus already. When the contacts with my specific identifier don't exist yet, they are created successfully by the pipeline. The problem is that I'm not able to update the facet values (e.g. LastName in Personal) for those contacts without this facet.

For example, my contact_1 is updated successfully, because a have created the LastName facet's property for it before. On the other side, my contact_2 is not updated properly (the LastName facet's property) just simply because that contact didn't contain that Personal facet at all.

What am I missing here?

More info:

I'm probably missing some basic point... I'm using the xConnect Entity Facet Property Value Accessor for writing the value to xConnect. When I'm debugging the code I can see that the writer is trying to read the facet's value exactly before it's going to write the new value. In case there is no facet value so far, the reading fails together with the whole mapping for that field... I was looking for some option on the accessor to turn off such behavior :), but without any success :(

  • Are you using xConnect Provider for Data Exchange Framework 2.0.1? – Vlad Shpak Aug 9 '18 at 14:19
  • Yes, I'm using exactly this provider. – rene naplava Aug 10 '18 at 19:57
  • You can review xDB Data Migration Tool. It creates new contact and adds new facets. – Vlad Shpak Aug 13 '18 at 8:51
  • Actually, I have used a similar approach @VladShpak ... I installed the Sitecore Connect for Microsoft Dynamics 365 for Sales Examples and according that I've used Value Accessor with Raw Value Reader Set as a source accessor in the value mapping used by Apply Mapping Pipeline Step. The target accessor here is an instance of the xConnect Entity Facet Value Accessor which is actually mapping the values from Service Bus to xConnect facet's properties.By this approach I'm probably creating the facet as well (not just the properties). And I assume that this was the main problem... – rene naplava Aug 16 '18 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.