0

Exporting an SXA 1.8 site (SC9.1) with Creative Exchange generates the static files, however the asset URLs in the exported HTML contain hyphens, whilst the folder structure from the zip file contains spaces, so the links are broken when previewing the static HTML pages.

For example:

<link href="-/media/Feature/Experience-Accelerator/Bootstrap-4/Bootstrap-4/Styles/optimized-min-1.css" rel="stylesheet">

which should refer to a folder:

-\media\Feature\Experience Accelerator\Bootstrap 4\Bootstrap 4\Styles

How can I get the exported HTML to align with the theme folder names?

I am using an IIS site mapped to the static assets, not just loading the files from disk to a browser. Site was exported as an Agency Drop. EncodeNameReplacements is turned on in Sitecore config for spaces to hyphens out of the box, however disabling this doesn't fix the issue as the URLs with spaces still break.

0
1

Optimize-min files should not be exported. This might be a bug, please contact Sitecore support.

As a workaround please turn off asset optimization and try to export again:

enter image description here

2
  • Thanks Dawid, turning off optimisation fixed the file names. Paths still have spaces but I can workaround. Will log a bug report. – andyp Jan 14 '19 at 20:55
  • Sitecore have raised a bug report. Will report back here. – andyp Jan 16 '19 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.