0

I have a sitecore 8.2u7 as PaaS and when I try to load a js file in the browser , it shows an error and in the log I get this message

I checked in the configuration files for any parameter but I can't find anything

Anyone can say what is this ?

ERROR [Bundle]: Error running bundle pipeline - bundle.beacon
Exception: System.ArgumentException
Message: The URL '~d:\local\temp\beacon_47542.js' is not valid. Only application relative URLs (~/url) are allowed.
Parameter name: virtualPath
Source: System.Web.Optimization
   at System.Web.Optimization.Bundle.Include(String virtualPath, IItemTransform[] transforms)
   at (Object , Object )
   at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain)
   at Sitecore.Abstractions.CorePipelineWrapper.Run(String pipelineName, PipelineArgs args)
   at Sitecore.FXM.Bundling.BundleRegistrar.GenerateAndRegisterBundle(String bundleIdentifier, PipelineArgs args)
1

Ensure that the location of the Temp folder is in your \Website folder. use a relative path. For Sitecore 9 you can specify that in the FXM.BundledJSFilesPath setting in the Sitecore.FXM.config file.

Probably the same for Sitecore 8.2, Else take a look at your config files and search for d:\local\temp you can also use the /sitecore/admin/showconfig.aspx url to take a look at your config. See FXM issues looks like old Sitecore versions use this variable <sc.variable name="tempFolder" value="/temp"/>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.