0

Have an issue with Sitecore Horizon where I have installed it with a self-signed cert and now I'm swapping it for a real certificate and a proper domain. I did the same for Identity server and it was fine however when I try this for Horizon it seems to give me this error.

I've updated IIS with the custom domain and I am using a wildcard certificate which is a client/server cert (works for Identity and XConnect). Spinning up Horizon seems to use Network Service on the App Pool which i've given Read permission on my custom Cert. I've also tested giving "Everyone" access and it made no difference.

Just wondering if anyone can think of something I may have missed here?

GraphQL.ExecutionError: Error trying to resolve sites. ---> System.Net.Http.HttpRequestException: The SSL connection could not be established, see inner exception. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.
   at System.Net.Security.SslState.StartSendAuthResetSignal(ProtocolToken message, AsyncProtocolRequest asyncRequest, ExceptionDispatchInfo exception)
   at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
1

You can try searching the old certificate thumbprint in the Horizon website folder.

Next, replace this with new certificate thumbprint.

Check if this works

  • Thanks @Himanshu, I've already had a look for the old thumbprint and just had another look to be doubly sure, but there are no references to the old thumbprint anywhere.. – Dave Goosem Feb 23 '20 at 23:21
1

So after revisiting this fresh, embarrassingly the logs also showed messaging about the GET request to an address that was local to the server (from my installation).

I'd since updated with non-local DNS and must not have saved my change to the /Config/Sitecore.Horizon.API.Gateway.config file with the publically accessible url within this tag:

<SitecoreHost>https://mysite.com</SitecoreHost>

I updated this and it's working. Figured I'd post the solution in case someone else spins up a local install and then makes it public facing. There are also identity server endpoints to update in config settings in /Config/openIdConnect.config

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.