I'm currently following this tutorial: https://doc.sitecore.com/developers/90/sitecore-experience-manager/en/walkthrough--creating-a-custom-form-element.html

I'm on the final part: Configure the field editor parameters > Create the field type item

I can't seem to find my get my item from the core database for the Property Editor value. All I get is the following:

enter image description here

Am I missing something?

I'm currently on Sitecore 9.0 - I cannot upgrade.

  • Based on the steps described you should be on master DB and look for "/sitecore/system/Settings/Forms/Field Types/Basic". Why are you searching for it on the Core DB? Oct 16, 2020 at 7:48
  • Following on the tutorial, it said: Property Editor – point to the item you created earlier. For example, select the property editor for the Video item. From what I can tell its the item I created in the core database at /sitecore/client/Applications/FormsBuilder/Components/Layouts/PropertyGridForm/PageSettings/Settings
    – James
    Oct 16, 2020 at 8:34
  • You are correct. That field "Property Editor" looks for value in the CORE db. Are you not seeing this folder "/sitecore/client/Applications/FormsBuilder/Components/Layouts/PropertyGridForm/PageSettings/Settings" in the CORE db? Oct 16, 2020 at 9:52
  • The screenshot in my original post shows what I can see when I click on Property Editor. It looks like its only looking at the master database rather than the core database. If I manually add the guid key (enabling raw values) it just says I have a broken link
    – James
    Oct 16, 2020 at 10:14
  • 1
    Yes! that worked. It seems like it went missing at some point. Thanks for your help :)
    – James
    Oct 16, 2020 at 12:32

1 Answer 1


The field Property Editor of the template /System/Forms/Field Type - {A60EDCAF-1285-46B5-8380-D790BB8C8708} was missing the source.

Updated the source of the Droptree with source as DataSource={0E723521-4594-4785-AECE-CEB7BB2FB4E0}&DatabaseName=core.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.