1

I have created a bucket without any rules set i.e. it's structure is default. Now I am trying to create the rules for the bucket but the latest rule is not getting synced. I tried with both i.e. out the box Sitecore bucketing rules and custom rules, none seem to work.

Below is the structure of my bucket items.

enter image description here

I created my own rules. Below is the screenshot of Rules and the code:

enter image description here

enter image description here

But it didn't work and even after syncing the structure of bucket remains the same. I thought there might be some issues with my code. Then I tried to give it the Rule which is defined in the sitecore. enter image description here

This also didn't work.

6
  • Welcome to Sitecore Stackexchange, could you add more details and printscreens to the question like how your bucket looks like and what rules you have defined? Jun 17 at 9:36
  • @CristiVulturar : I have edited the question. Please suggest if you have any idea on the same. Jun 17 at 10:35
  • If you have sxa you need to add the rule at the site settings level as this item buckets setting won't affect the SXA sites, Sxa has its own SiteBucketPathProvider. There is a field called Rules for Resolving the Bucket Folder Path on the Sxa Site -> Settings item. Jun 17 at 12:16
  • @CristiVulturar: Thanks a lot for the help. It worked. I have never worked on a SXA site, so never knew we have this setting also. Thanks a lot. Jun 17 at 13:37
  • Added an answer aswell so the question can be marked as answered. Jun 17 at 15:52
2

If you have SXA the Item Buckets Settings from /sitecore/system/Settings/Buckets/Item Buckets Settings won't be taken into consideration as SXA has its own provider for the buckets. You can find it defined in /App_Config/Modules/SXA/Foundation/Sitecore.XA.Foundation.Multisite.config:

<setting patch:instead="*[@name='BucketConfiguration.DynamicBucketFolderPath']" name="BucketConfiguration.DynamicBucketFolderPath" value="Sitecore.XA.Foundation.Multisite.Buckets.SiteBucketPathProvider, Sitecore.XA.Foundation.Multisite" />

In order to fix this you will need to go to the SXA Site -> Settings item and add your custom rules to the field Rules for Resolving the Bucket Folder Path. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.