2

I have a site whose production instance is hosted in Germany, which we are currently upgrading (8.2 to 10.1). We have decimals that are displayed on the site, and because the prod server is German the decimal separator is showing as a comma.

Yes, I know that I could format every decimal output in my code with the correct locale or convert to string and do a string replace, but we had this fixed in the old production instance (which is on the same server) and the exact same code is being used, so I'm trying to figure out how we fixed this before -- it is NOT a server setting (as it's the same server), and I shouldn't have to make any code changes since the code is outputting the correct decimal format in 8.2, so I figure there must be a Sitecore configuration setting that I'm missing.

So, how can I globally set the decimal delimiter to use a period instead of a comma?

1 Answer 1

6

While I can't tell how you fixed it before, one option is to just force the culture settings you want in web.config.

E.g. <globalization uiCulture="es" culture="es-MX" />

Reference: https://learn.microsoft.com/en-us/previous-versions/aspnet/bz9tc508(v=vs.100)

1
  • 1
    That's exactly it. The 8.2 instance had <globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="en-CA" uiCulture="en" /> and that was missed in the new instance web.config, but because it's in web.config I couldn't find that in the sitecore showconfig. Thank you! Dec 19, 2022 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.