5

In Sitecore habitat project, I am running task '05-Sync-Unicorn' in VS task running explorer but it does nothing and just displays "Starting '05-Sync-Unicorn'" in console (even doesn't produce any error in console).

  1. What can be the possible reasons?
  2. Where can I see GULP tasks log in VS?
  • Any errors in your Sitecore log file? Also try going to habitat.dev.local/unicorn.aspx and running the sync manually - any errors with that? – Richard Seal Dec 17 '16 at 15:15
  • running the sync manually works but doesn't work through gulp task.In sitecore log i cant see any error although there are few warnings. Is there any other log other than sitecore log for gulp tasks? – S.Kazmi Dec 17 '16 at 15:32
  • Make sure that this /scripts/Unicorn/MicroCHAP.dll isn't blocked by windows (right click on the file, properties, unblock). Also make sure that App_Config/Include/Unicorn/Unicorn.UI.config is in your website and has the <SharedSecret> in it. – Chris Auer Dec 17 '16 at 20:45
  • dll in Scripts folder? dll in bin is surely not blocked and everything else you mentioned are in place – S.Kazmi Dec 17 '16 at 21:07
  • I thought that VS task runner wouldn't do the unicorn because it was ES6. can you open a command prompt at the root of the project and type "gulp 05-Sync-Unicorn" and hit enter. Also are you using the habitat.dev.local for your site url? – Chris Auer Dec 18 '16 at 2:23
2

Even I faced similar issue..The task would start and hang up with the below message Starting '05 Sync Unicorn'.. As mentioned above , along with MicroCHAP.dll, I had to unblock other two files (Sync and Unicorn ) to resolve the issue.

0

I had this same problem, and on inspecting my Sitecore log, I found multiple instances of the following error:

Unable to resolve serialized item for included root path master:/sitecore/system/Settings/Feature. The item does not exist in Serialization File System Data Store. It has been skipped. Perhaps you need to perform an initial serialization from the control panel?

This fixed worked for me:

  • Uninstall Sitecore instance (/habitat.dev.local)
  • Reinstall using SIM, ensure you use the exact version listed in the current version of the Habitat installation notes (for me, it was Sitecore 8.2 Release 1).
  • Install the WFFM module. Make sure you use the correct version as listed in the Habitat installation notes (for me, it was Web Forms For Marketers 8.2 rev 161129)
  • Make sure you complete the WFFM post-install steps (adding to the Web.Config and running SQL scripts).
  • Now run npm install and gulp on your Habitat src folder, as per the habitat installation notes.

Once I resolved the slight mismatch between versions of Sitecore, WFFM and the Habitat source, Unicorn ran fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.