1

Using Sitecore 10.1.2

In my local machine, I have installed the instance and deployed the code and Sitecore items. The solution uses TDS.

This is a multi-site project and one of the Site Grouping items is like this:

----field----
field: {475031D8-724D-463C-80B2-90839DD1AD98}
name: VirtualFolder
key: virtualfolder
content-length: 1

Meaning, there is no field value, but still the content-length is 1.
Could this be a reason. But isn't this a content item. Will the CMS still not load because of this? Even the login page isn't loading.

Anyways, I added / as the field value in the code for that item and then tried to do TDS Sync with Sitecore. But it throws an error saying:

enter image description here

That's because the CMS isn't loading.

Wen I browse my CMS, it throws this error:

The path must start with a '/' followed by one or more characters. Parameter name: value
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentException: The path must start with a '/' followed by one or more characters. Parameter name: value

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[ArgumentException: The path must start with a '/' followed by one or more characters. Parameter name: value]
Microsoft.Owin.PathString..ctor(String value) +119
Owin.MapExtensions.Map(IAppBuilder app, String pathMatch, Action`1 configuration) +108
Sitecore.Owin.Authentication.IdentityServer.Pipelines.Initialize.LogoutEndpoint.Process(InitializeArgs args) +244 (Object , Object ) +14
Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) +490
Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists) +236 Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) +22

[TargetInvocationException: Exception has been thrown by the target of an invocation.] System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) +0
System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) +216
System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +182 Owin.Loader.<>c__DisplayClass19_1.b__0(IAppBuilder builder) +93
Owin.Loader.<>c__DisplayClass9_0.b__0(IAppBuilder builder) +224
Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) +897 Microsoft.Owin.Host.SystemWeb.OwinBuilder.Build(Action1 startup) +51 Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() +101 System.Threading.LazyInitializer.EnsureInitializedCore(T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory) +139 Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context) +160
System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +584
System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +168
System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +277
System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +369

[HttpException (0x80004005): Exception has been thrown by the target of an invocation.]
System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +532
System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +111 System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +719

UPDATE:

The Sitecore items were only pushed to master and I never published to web.
So, in the Connectionstrings.config, I pointed master also to the web database and now the CMS loads fine. (ofcourse without the content items).

Is there a way to fix this other than reinstalling the instance?

2 Answers 2

1

Try login without the identity server by following this approach.

To prevent Sitecore from redirecting users away from the sitecore/login page.

  1. Patch the shell login page back to /sitecore/login, or request /sitecore/login with extra an URL parameter (?fbc=1).
  2. Alternatively, patch the legacyShellLoginPage property of the InterceptLegacyShellLoginPage processor to some random value.

Either of these actions prevents Sitecore from redirecting users away from the /sitecore/login page. The SI server is configured as a regular external identity provider in Sitecore and it means you see its sign-in button on the /sitecore/login page. The caption is Go to login.

Refer to the Sitecore article for Disabling Sitecore Identity.

If this works, you can modify the item that is creating the issue and then revert it back.

Hope this works.

1

If you suspect TDS installation or sync could be a reason then you can also try removing TDS stuff from your webroot.

Sitecore TDS installs a web service on the target Sitecore instance to communicate with Sitecore. The service is installed in the webroot/_Dev folder and a .dll is copied to the /bin folder. Try to search DLLs starting with hedge word and remove it.

Also as per your updated description, it looks like you lost content from the master db and that could be a potential issue. You can give it a try to create a master db using Sitecore.Master.dacpac file in a vanilla state. You will find this in .scwdp.zip file and then update the connection string to point newly created db.

Hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.