0

We have added languageEmbedding : never in our Sitecore SXA site. We are not getting language in the URL when we open site directly.

However, when we are searching any result on google and redirect that page from search result then it is showing the languages in the URL.

Https://example.com/en/testpage

Could someone assist me why this is happening? We do not want to show language in the URL after searching in google search.

Updated : It's happening only on google search. Other browser such as bing and yahoo are showing the correct results without adding language in the url.

1
  • can you check in show config file is anything is overrided Aug 20, 2023 at 16:08

2 Answers 2

0

Two things to look at.

  • The canonical url on your pages.
  • What is in Sitemap.XML

Without knowing more about your solution, it's not really possible to point you in a more specific direction.

2
  • we are not using any canonical url and Site map.xml in our site.
    – Nisha
    Jul 21, 2023 at 10:03
  • I have just checked related to site map.xml file on browser. It is creating , by default and it is showing url without em bedding language there.
    – Nisha
    Jul 21, 2023 at 10:42
0

Here are a few potential reasons and solutions for this issue.

Google Cache: Google might be caching old versions of your pages where the language was included in the URL. You can request Google to recrawl and update its cache using Google Search Console.

Canonical Tags: Ensure that you have implemented canonical tags correctly on your pages.

Sitemap: Check your sitemap to ensure that it reflects the correct URL structure without language embedding.

Check Meta Tags: Ensure that the meta tags on your pages are correctly configured, including the language meta tag

<meta http-equiv="content-language" content="en">

Google Search Settings: Users' Google search settings might also affect how URLs are displayed in search results. However, this is unlikely to be the main issue since other search engines like Bing and Yahoo are showing the correct results.

Since the question was posted a while ago but hope this helps who are still facing the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.