0

hey folks I'm running an upgrade package on sitecore 8.0 (from update 3 to 7) and I noticed it started taking a long time to process. I verified the logs and ran into hundreds of these error messages: Access to the path E:\dictionary.dat is denied.

Funny thing is that there is no E drive on this server. As far as I know the dictionary.dat should be on the temp folder but Sitecore seems to be looking at the E drive. anyone ever seen this?

UPDATE 1: By the way this is the same package I have used to UPGRADE a DEV and a QA environment but this is happening only on PROD

UPDATE 2: I have tried all sugestion and none addressed the issue. I did notice one thing. Every time I restart IIS the error will jump from one drive to the next letter. It started with E drive. Then F. I restarted IIS and now it's looking on G drive. Even if I hard code the path of the temp folder to the temp folder of the website folder as in D:\thewholepath\Website\temp Maybe it's worth mentioning that I got a copy of the existing website and data folders, restored a backup of the databases from a running environment and created a new IIS site and pointed to it. Sitecore loads fine. No errors on logs. These errors do happen when I try to run the upgrade package. Any other thoughts?

Running out of ideas here

10
  • What's the tempFolder value set in your config file? Default: <sc.variable name="tempFolder" value="/temp"/> Feb 1, 2017 at 19:51
  • it's the defautl value "/temp"
    – Diego
    Feb 1, 2017 at 19:57
  • 1
    Can you check the value through the admin interface? I'm thinking it may be overwritten in another config file. /sitecore/admin/showconfig.aspx
    – Koen Heye
    Feb 1, 2017 at 20:14
  • could you check using showconfig.aspx page, there is a possibility someone might have added a overwrite for that. If you already did that, ignore this message Feb 1, 2017 at 20:15
  • thats what I did. this is coming from the showconfig sorry I was not clear about it
    – Diego
    Feb 1, 2017 at 20:24

4 Answers 4

1

What we know (or assume to know) to be true

  • Sitecore runs fine
  • Fails when trying to install an update package
  • Fails because it's trying to write to a drive/path that does not exist
  • Only happens in production. Other environments are fine.
  • Referenced drive/path (E:) is not to be found in any configuration files

What we also know

Hypothesis

Something is wrong with yout %TEMP% or %TMP% environment settings. They either point to lala land or... :

  • Either your AppPool Identity user does not have full access to said folder (which could be the case with overzealous security hardening only done on production, not other environments).
  • Or you are running Network Service as AppPool Identity and THAT doesn't have required permissions on the folder

Proposed Solution

Depends a bit on what the problem is. Check the environment settings for %TEMP% and %TMP%. A quick way to test, would be to set the AppPool Identity to Local User and provide admin credentials to it. DO NOT LEAVE IT LIKE THIS however, only use it to see if it's a permissions issue or if the %TEMP% setting is outright wrong.

If the site starts working after you've set Local User, it's a permissions issue. Find out where %TEMP% points, and grant your AppPool Identity user full control on the folder.

If it still doesn't work, figure out what the %TEMP%/%TMP% variables are set to, and fix them.

A few references:

3
  • 1
    thanks for the explanation. I have reviewed all the steps and found the problem. I had set full control on the network service on the website and data folder BUT while creating the new site did not change the app pool to Network service causing this permission issue. what still gets to me is why it was looking for non-existing drives. Either way we found the problem.
    – Diego
    Feb 2, 2017 at 23:03
  • 1
    Yea I still have no explanation for the weird drive letters. I just know that Website and Data folder isn't enough, the system %TEMP% folder sits elsewhere. Glad it's solved though :-)
    – Mark Cassidy
    Feb 2, 2017 at 23:15
  • The non-existent drives and changing drive letters is a fascinating symptom. Feb 3, 2017 at 11:01
1

Another thing you can do to troubleshoot it is search for E:\ using a grep tool such as astrogrep. It might take awhile, but you might find out what exactly is referencing the E:\ since it searches the inside of files.

0

Probably you have to clear your cache for Dictionary through Sitecore.Globalization.Translate.ResetCache(true); if you have less impact while clearing cache on production environment please try from powershell console enter image description here

And your log entry could be enter image description here

1
  • you need to upgrade your SPE! :) Feb 3, 2017 at 1:36
0

Set the temp variable to an absolute path i.e. D:\Temp and check again, if it's still looking in E:\ get a Grep tool like RReilley's answer (I use 'PowerGrep' https://www.powergrep.com/download.html ) and look for any reference to drive E:

If still no joy, start looking at IIS config for anything odd, virtual folders etc.

1
  • I forced the path to the temp folder but that didn't work. Also no virtual directories pointing to E drive on IIS
    – Diego
    Feb 2, 2017 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.