1

I have a Sitecore user who is not an administrator. I want to add any language version of an item from more languages button available in the top right corner of an item even though that language is not available under sitecore/system/languages. When I was trying to do that I was getting an error like below

The security settings for the current language prevent you from seeing this item.

To continue, select another language from the Language drop-down list on the Versions tab.

The error will not be coming when this is done as a administrator.

Can anyone tell me what are the rights that needs to be given to the sitecore user so that he can also add any language versions for an item just like an administrator?

  • I don't think it's a recommended solution to have a language version of an item using language which is not defined in your Sitecore application. What is the reason you want even use it? – Marek Musielak Nov 27 '17 at 7:54
  • I don't know what is the exact reason. It was a task allocated to me. – user2755 Nov 27 '17 at 8:25
  • not quite sure what role this is (if it even exists) but I agree with Marek, don't blandly do this as it will create problems further down the road. – Kris Verheire Nov 27 '17 at 8:29
  • Bcoz, i was given a task to resolve the below issue for a particular sitecore user -The security settings for the current language prevent you from seeing this item.To continue, select another language from the Language drop-down list on the Versions tab.For this i added a language as administrator and given the language read and write permissions which resolves the issue for the sitecore user.But the team is saying that you shouldn't add a language but should grant the rights in such a way that it works just like the administrator does. – user2755 Nov 27 '17 at 8:37
2

Before I answer your question, let me give you a quick free advice: Don't do this. Adding language versions in languages which don't exist in the system will cause more problems later.


The only option you can do this is to make your user an administrator (User Manager, select user, Is Administrator checkbox).

The reason why there is no other option is that Language Read and Language Write rights are set on /sitecore/system/Languages node and inherited by all the languages defined in system. If your user is not administrator, Sitecore cannot find language node to check the security and returns Access Deny.

For Sitecore Administrator, that security is ignored.

There is no Sitecore role which can be assigned to your user to bypass this security check.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.