4

In general, you can look at the examples in the documentation for searching contacts by an interaction facet: https://doc.sitecore.net/developers/xp/xconnect//xconnect-client-api/search/contacts/index.html#search-by-interaction-facets I'm sure this is what you based your queries on, but including it for completeness. I notice in your code that you are ...


4

You should get a contact with expanded interactions which will contain page events. private async Task<IReadOnlyCollection<PageViewEvent>> GetAllPageEvents(Guid contactId) { var allInteractionsExpandOptions = new ContactExpandOptions() { Interactions = new RelatedInteractionsExpandOptions() { ...


3

I have found answer. You need to add Webvisit into your interaction and specify SiteName there :) // Create a new web visit facet model var webVisitFacet = new WebVisit(); // Populate data about the web visit webVisitFacet.Browser = new BrowserData() { BrowserMajorName = "Chrome", BrowserMinorName = "Desktop", BrowserVersion = "22.0" }; webVisitFacet....


3

from your code getContact != null, if this condition is false, then you are creating new contact which is incorrect. Contact contact = new Sitecore.XConnect.Contact(new ContactIdentifier(phoneAsChannel, contactus.email, ContactIdentifierType.Known)); Sitecore has already created an anonymous contact and set it in the device cookie ...


2

Updating interaction facets is definitely something that has been discussed but at the current time it is a product decision to keep these consistent. If you wish to 'change' the value of an interaction, you need to delete the existing one and create a new one. (This leads to the next problem where you cannot currently delete a single interaction via the API)...


2

You can try using the rule where the visit no. compares to number. Here you can set the number of visits for which the component will be visible for the user.


1

So you're accessing your own local instance of Sitecore from the same machine where the instance is deployed. That's why you're getting 127.0.0.1 as the IP, cause it's your local IP. If you want to test GEO IP locally you should set the Analytics.ForwardedRequestHttpHeader setting: <setting name="Analytics.ForwardedRequestHttpHeader" value="X-Forwarded-...


Only top voted, non community-wiki answers of a minimum length are eligible