3

We are having problems loading droplist Name/Value pairs when the datasource is Sitecore items. When I open the WFFM form designer, select the droplist field and choose some items for it I get the following console error:

enter image description here

error message

Mixed Content: The page at 'https://cms.mydomain.org/sitecore/shell/Applications/Content%20Editor.aspx?sc_bw=1' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://cms.mydomain.org:8003/sitecore/shell/~/xaml/Sitecore.Forms.Shell.UI.Dialogs.ListItemsEditor.aspx?params=%7B048301D3-8A1A-4D3A-ABED-B34782EC3CD9%7D&id=%7B34E80614-F04B-4E8B-8FAD-3E2F48467001%7D&db=master&la=en&vs=1&target=pb_forms_loc_Items&Cart_ctl00_ctl05_ctl00_ctl00_ctl05_ListItems_Callback=yes'. This request has been blocked; the content must be served over HTTPS.

The CMS server is setup via WebFarms/loadbalancers and is using a valid wildcard domain certificate. Seems like intermediate calls are not being directed to https via loadbalancer ? Anyone seen a similar issue ?

The Sitecore Version is 8.0 (rev. 160115) (8.0 update 7/Service Pack-1)

  • Do you have scheme="https" attribute set on your <site> node in config? – jammykam Feb 26 '18 at 21:03
  • 2
    Does this answer help? sitecore.stackexchange.com/a/10427/95 I found that I needed to change the CSP for Chrome to allow the request. – Michael West Feb 26 '18 at 21:16
  • Are you rewriting your URLs? The intermediary requests won't pick up on the HTTPS since it's probably using the LinkManager to generate the URL. I would look into @jammykam's recommendation above on setting scheme="https" on your Sitecore site or use the URL Rewrite module to rewrite all HTTP requests to be HTTPS. – George Chang Feb 27 '18 at 17:02
  • I added both the scheme="https" and the CSP recommendations as mentioned by @jammykam and Michael West . Now I get the second URL with https but with port number and is timing out. We do have a blank http to https rule setup for all. 'cms.mydomain.org:8003/sitecore/shell/~/xaml/… – Naveed Ahmad Mar 1 '18 at 19:56
  • Sorry, no idea where that port number is coming from, never seen that issue before. Check your config and make sure it is not specified somewhere. – jammykam Mar 2 '18 at 0:39
1

An absolute address generated on the server is being used instead of a relative address.

You can change this by editing /sitecore/shell/Applications/Modules/Web Forms for Marketers/script/Sitecore.Forms.ListItemsEditor.js

Adding the following on line 25 before the call to ListItems.callbackwill convert to a relative link

if (ListItems["CallbackPrefix"].indexOf("http") !== -1) {
    var anchor = document.createElement("a");
    anchor.href = ListItems["CallbackPrefix"];
    ListItems["CallbackPrefix"] = anchor.pathname + anchor.search;
    } 

It looks like this is fixed in Sitecore Experience Platform 8.2 Update-1:

The Port attribute is now taken into account when links are generated, enabling the configuration of environments with translation ports​​.

from https://dev.sitecore.net/Downloads/Sitecore%20Experience%20Platform/82/Sitecore%20Experience%20Platform%2082%20Update1/Release%20Notes

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.