3

I did an upgrade to SXA from version 1.6 to version 1.7.

After publishing my site, I got the warning message

Sitecore Experience Accelerator Content Upgrade Required

with an upgrade button. but when i click upgrade and open the Powershell script results i find it empty, it doesn't contain any upgrade steps!

However, i still get the same warning message even when i create a new site or a new tenant. Any clue why i keep getting this warning although the Powershell script results is empty ?

  • Did you perform any synchronization after the upgrade procedure? – Dawid Rutkowski May 13 '18 at 11:17
  • Same issue happened for me. I had to lower the version number for the upgrade to run steps. – Michael West May 13 '18 at 12:59
  • 1
    @DawidRutkowski No i haven't. turned out that it is an issue with 1.6 to 1.7 upgrade that there were no upgrade steps for this upgrade path so i had to change it manually by navigating to: /sitecore/system/Settings/Foundation/Experience Accelerator/Upgrade/Current and changing the number from 1600 to 1700. It worked successfully for me. – AmiraElEwady May 13 '18 at 13:18
  • 1
    We've created an issue in our backlog for this - it's a bug. – Dawid Rutkowski May 14 '18 at 13:00
  • 1
    @AmiraElEwady please add your solution as a self answer to the question. It will be useful to others. – Richard Seal Jun 29 '18 at 16:37
3

Turned out this is a known issue with 1.6-to-1.7 upgrade. There were no upgrade steps for this upgrade path, so just find this item :

/sitecore/system/Settings/Foundation/Experience Accelerator/Upgrade/Current.

and manually increase the number from 1600 to 1700

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.