6

We would like to inverse the logic and set the IndexAllFields property of the master index to false, so that only fields that are explicitly configured end up in the database. (Reason we are doing this has to do with the 1000 fields limit azure search)

Is there a list of fields that sitecore needs and should be added to the master index?

  • Hi Mark, I did read that question as well, but it does not answer the question I am asking here. The question you are referring to is related to sitecore 8.2 and the core index which was patched. My question is here to which fields the master index requires. – Bart Verdonck Jul 5 '18 at 15:40
  • Question is in dire need of clarification then, as both title and top half of the body circles around the Azure 1000 field limit. How is a search engine to tell them apart? – Mark Cassidy Jul 5 '18 at 22:32
  • I have stripped the question to it's bare essentials. – Bart Verdonck Jul 6 '18 at 6:51
8

If you came here because you are using Azure Search on Sitecore 9 and are over 1000 fields, then you can safely set IndexAllFields to false, however at time of writing there is one known issue (ref 229445) preventing Forms from working correctly in 9.0.2 and below. To correctly patch your config:

<sitecore role:require="Standalone or ContentManagement or ContentDelivery" search:require="Azure">
<contentSearch>
  <indexConfigurations>
    <defaultCloudIndexConfiguration>
      <documentOptions>
        <!-- We only want default fields in the core/master/web indexes on azure due to 1000 field limit  -->
        <indexAllFields>false</indexAllFields>
        <!-- Fix sitecore 9 forms issue 229445 -->
        <include hint="list:AddIncludedField">
          <isTemplate>{558F9307-EBAF-480D-88B5-DFE9E63A66DE}</isTemplate>
          <hidden>{39C4902E-9960-4469-AEEF-E878E9C8218F}</hidden>
        </include>
      </documentOptions>
    </defaultCloudIndexConfiguration>
  </indexConfigurations>
</contentSearch>
</sitecore>

Note that this only works for Azure search. Lucene and Solr have other fields missing too - you'll have to raise a sitecore support ticket for those.

  • I can confirm this, we had the same issue with forms module. Adding these fields solved this. – Bart Verdonck Jul 26 '18 at 9:19
2

When you set IndexAllFields to false the indexing system will still index certain fields that it needs.

I recommend setting that value and then add a single field. Then in Azure Search review what fields are index so that you can see what gets indexed. It's only a few fields.

  • I tried this which works for the most part but forms are not showing up in the results. Looks like some required fields for the sitecore 9 forms are not getting included automatically. Any ideas which ones? – Mark Gibbons Jul 23 '18 at 5:37
  • I'm not sure. I'm running Sitecore 8.2. – Kevin Jul 23 '18 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.