Skip to main content

Questions tagged [azure-search]

Anything related to Azure Search: querying, configuring, maintaining, ... Azure (PaaS) replacement for Solr and Lucene.

Filter by
Sorted by
Tagged with
0 votes
0 answers
26 views

Azure Search Provider does not index any template fields

The azure search based Sitecore instance deployed as App service does not index any fields defined in the template. I dumped the key:value from searchresult object's Fields and we got the following ...
John's user avatar
  • 91
0 votes
0 answers
33 views

How to construct a query to search any field in given page templates?

I have few page templates defined such as basic page, article page, event page, directory page and each of them has different fields. how do I construct a query in search api to query any item that ...
John's user avatar
  • 91
0 votes
0 answers
63 views

Rebuilding of xDB index stuck after 19-30 documents after scaling up Azure Search

We have an issue with Sitecore xDB index in Azure Search on Sitecore 9.1.1. Recently we tried to rebuild xDB index. It started without any issues but after indexing 3 million documents we ran out of ...
Marek Musielak's user avatar
  • 23.9k
2 votes
1 answer
148 views

Rebuilding of xDB index doesn't start after scaling up Azure Search

We have an issue with Sitecore xDB index in Azure Search on Sitecore 9.1.1. Recently we tried to rebuild xDB index but we ran out of storage - 25GB was not enough to keep xDB index, secondary xDB ...
Marek Musielak's user avatar
  • 23.9k
1 vote
1 answer
100 views

Switch on rebuild Sitecore 9.0.2 issue

We are using Azure search in Sitecore 9.0 update 2 version, We enabled switch on rebuild option to achieve 0 downtime during the rebuild. Every time when indexes (_sxa_web_index) rebuilding we notice ...
marwen1's user avatar
  • 13
3 votes
1 answer
325 views

In solr Master-Slave configuration custom indexes are getting out of sync sometimes in one of the slave servers

In our production environment, we have Master-Slave SOLR server configuration. We have 2 SOLR slave servers and configured SOLR load balancing URLs in prod CM and CD servers. Right now we are facing ...
Ruchi Gupta's user avatar
0 votes
1 answer
46 views

Sitecore 9.3 Azure Search multi-site search with separate indexes

Using Sitecore 9.3 and Azure search. We have a single Sitecore CM instance setup with two content trees: /sitecore/content/siteOne /sitecore/content/siteTwo We have separate CD sites for each of ...
T H's user avatar
  • 123
1 vote
0 answers
23 views

Azure Search and Linq for Exact Phrase [duplicate]

We are using Azure Search engine (I know...) and need to so a search for an exact phrase. Using the PredicateBuilder, if I have a statement like: keyword = "Mary Smith"; predicate = ...
Gary Williams's user avatar
0 votes
1 answer
81 views

Sitecore Azure index rebuild doesn't work with disabled indexAllFields

After migration from Solr to Azure Search I found the problem with a limited amount of fields for Sitecore indexes: core and master. In all articles\answers was suggested disabling of indexAllFields ...
Mickey P's user avatar
  • 175
0 votes
1 answer
213 views

How to migrate custom index configuration from Solr to Azure Cognitive Search?

I am trying to switch from Solr to Azure Cognitive Search in Sitecore 9.1, but for some reason my fields are not shown in custom index after migration. Solr custom index configuration: <...
Mickey P's user avatar
  • 175
8 votes
3 answers
2k views

Could not find add method: AddIndex (type: Sitecore.ContentSearch.ContentSearchConfiguration)

We are setting up a new Sitecore 9.3 instance on a server, making the respective connection string changes and getting the below error while loading the Sitecore login page: Error: Could not find add ...
Geetha's user avatar
  • 133
0 votes
0 answers
110 views

Getting error in Azure search ""Index was out of range. Must be non-negative and less than the size of the collection.\r\nParameter name: index"

We are getting result thorough content api using Azure search and solr. In Solr, everything is working fine but when we are trying to get result in Azure search then we are getting the below error
Ashu's user avatar
  • 402
0 votes
0 answers
285 views

Browser is unable to load pdf documents from Azure CDN

we are getting an error when the browser is trying to download pdf documents. we are getting an error i.e. Failed to load the document. This error we are getting for pdf files that are greater than ...
Lava's user avatar
  • 11
3 votes
1 answer
206 views

Getting extra results in content search result with Azure Search

Using Azure search in Sitecore 9.1.1. We are getting extra results in Azure search only, with Solr results are showing correctly. Scenario: Fetching result from the below structure : When we try to ...
User7864's user avatar
  • 219
0 votes
2 answers
268 views

Where to get Azure search query logs to check a query?

We are using Azure search to get the Sitecore items based on some filter conditions passed as predicate. This condition is not working with Azure Search in our dev environment. We have to check the ...
Deepak Sharma's user avatar
3 votes
2 answers
229 views

How to create a custom facet for a Time range for an SXA search filter

I have a search result component showing all the events. The requirement is to add a CheckList filter to filter the events that have their event date before 9AM and after 9AM. How can I create a ...
Barada behura's user avatar
0 votes
1 answer
133 views

New field for Azure index

I have Sitecore 9.3 with Azure PAAS and are using Azure search. I added one 'shared' field to the media templates of the checkbox type with name IsOptimized. I added the following entry to the config. ...
NutsAndBolts's user avatar
  • 1,342
0 votes
1 answer
109 views

GroupBy clause for both search providers (Solr, Azure)

Would like to use groupby clause in Sitecore 9.1.1 for both search provide (Azure, Solr) in content search API. However, Sitecore does not support this clause. Kindly let us know how we can group ...
Ashu's user avatar
  • 402
1 vote
0 answers
512 views

How to build Sitecore SXA Scope Search query with comoperations

I have requirement to show the query results based on the logged-in user-profile details, I was able to pass the query token field value dynamical by following the code. How to write a SXA search ...
KARASH's user avatar
  • 11
2 votes
0 answers
115 views

Exact search in Azure search in Sitecore SXA

Using azure search in Sitecore SXA 1.7 and it is not fetching exact result likewise if we are using "Test data" in search box then it is showing result based which match "Test data ...
Ashu's user avatar
  • 402
0 votes
1 answer
169 views

Sitecore doesn't add the indexed field with Traditional Chinese & Simplified Chinese postfix on the Azure custom index

I am doing a POC in Sitecore.Net 9.2 vanilla setup for enabling the Traditional Chinese and Simplified Chinese in the CMS and looking for how can I perform the Azure search for the content in zh-HK ...
Kuldeep Sharma's user avatar
3 votes
0 answers
248 views

Not able to fetch search result in Content search API with Solr and Azure

I am using content search API in Sitecore 9.1.1. However, it is not fetching result if i am using search with any of the template field. The below code fetching result based on template id but when we ...
Ashish's user avatar
  • 912
2 votes
1 answer
1k views

Could not compute value for ComputedIndexField - Service Host URI is not a Valid URI

We have a sitecore 9.1.1 CM instance configured to use Azure Cloud. We have the relevant configurations enabled & disabled for each instance. However we are seeing the following: 16784 22:55:11 ...
Anicho's user avatar
  • 1,429
1 vote
1 answer
78 views

How to index Catalog Generated Template Field's in Azure search

In Azure Search Index configuration, there is an option to include Fields that need to be indexed. But the catalog generated Templates Field may be having different id's in different environments (Dev,...
Jinu's user avatar
  • 117
2 votes
1 answer
347 views

Custom Sitecore index not updated on publish after item delete

We are using Sitecore 8.2 with Azure search. When I delete an item and publish the parent folder, the item goes away from sitecore_web_index, however, it doesnt go away from the custom_web_index. (I ...
Durga Bose's user avatar
2 votes
1 answer
105 views

Automated index document merge complains about invalid index name but index names are valid

I get thousands of the following error in the minions log: 00007 09:21:07 ERROR AzureContextCommand.MergeOrUploadDocuments.Error: Message=Index name must only contain lowercase letters, digits or ...
lcaaroe's user avatar
  • 23
3 votes
1 answer
133 views

Custom index was not found error in in Azure Paas Content Delivery

My custom index "custom_index" was not found error is coming in Sitecore 8.2 on the Azure Paas CD environment. But the same custom_index is accessible in the CM environment. I'm using the Azure ...
Sathish Kumar's user avatar
0 votes
0 answers
71 views

How can I solve Server Error in '/' Application Index has not been initialized? [duplicate]

If I access my home page, show error like this : Server Error in '/' Application. Index has not been initialized. Description: An unhandled exception occurred. Exception Details: System....
moses toh's user avatar
3 votes
1 answer
625 views

Index has not been initialized error on Sitecore 8.2 with Azure Search

I have Sitecore 8.2 update 5 in Azure PaaS using Azure Search. When I am trying to open the content editor, it is throwing exception Index has not been initialized with stack trace info mentioning ...
Somenath's user avatar
1 vote
0 answers
164 views

Azure search Synonyms implementation using SXA 1.9 and Sitecore 9.2 using postman API

I have requirement to work with the synonyms for the similar group of words in search. I did load the synonyms using Postman API to SXA web index and able to see them on the index. For example: home,...
Raju Balagam's user avatar
4 votes
3 answers
690 views

How to rename Azure Search index

I tried to index master, web indexes using the Azure Search service. Indexing works fine, but we have a requirement to have the index names unique in Azure as we are using single search services for ...
karthik's user avatar
  • 71
1 vote
0 answers
263 views

Sitecore Azure search suggesting index rebuild error

I have implemented Sitecore Suggesting search on Sitecore 9.2. based on https://sitecore.namics.com/2018/06/15/sitecore-9-azure-search-suggestions/ but when I rebuild indexes, I am getting error: ...
Arbejdsglæde's user avatar
3 votes
0 answers
77 views

Safe to delete Sitecore master/web old index after rebuild/swap?

We're using the Swap and Rebuild feature of Sitecore 9.1 when we need to rebuild our indexes for Azure Search. Occasionally, after the rebuild and swap is complete; Sitecore won't delete the old ...
Frank Rosario's user avatar
1 vote
0 answers
228 views

How can create new score profiling into Sitecore?

I am indexing Sitecore items into Azure and performing the Azure search via Azure functions. I want to create a new Scoring Profile into Sitecore and use it during the search. I am not getting much ...
Kuldeep Sharma's user avatar
3 votes
1 answer
315 views

How to replace `CertificateHttpClientHandlerModifier` to `X509Certificate2`

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on azure app service connects to XConnect which is also on Azure, am following this link ...
Fatema elsayed's user avatar
3 votes
1 answer
338 views

Connecting two Azure services to access XConnect

I'm using Sitecore 9.2 scaled environment on Azure, and am trying to make a .Net core 2.2 project published on app service azure connects to XConnect which is also on Azure, am following this link ...
Fatema elsayed's user avatar
0 votes
2 answers
492 views

Enabling full text search on a single line text field

Locally I successfully enabled full text search on a field in the sitecore_web_index by implementing the following logic in my Sitecore solution: 1) Added this xml to a patch configuration file: &...
R. Allinson's user avatar
1 vote
0 answers
164 views

Custom Azure Index doesn't update on CD Servers after rebuild

We have a custom Azure Index which we have enabled switch on rebuild for. The works fine on the CM servers but. However on CD we get no data showing until we restart the Azure App Service for the CD....
Adam Seabridge's user avatar
6 votes
1 answer
152 views

Azure Deployment Slot Processing Events and Updating Indexes

We have a deployment slot that we deploy to, which we then warm up, and then swap with the live slot so that we can achieve zero downtime deployment on PaaS. This works very well in general. However, ...
Matthew FitzGerald-Chamberlain's user avatar
1 vote
1 answer
1k views

Could not create instance of type: Sitecore.ContentSearch.Azure.CloudSearchProviderIndex. No matching constructor was found

Currently in progress of upgrading from Sitecore 8.1 to 8.2 update 7. So I'm currently converting existing indexes from luecene to Azure search, I have done all the basic steps like, disabling all the ...
karthik's user avatar
  • 71
1 vote
1 answer
385 views

IS there a simple way to get the current Azure Search index name programatically?

I need to get the current active index name for Sitecore search for logging purposes. Because of the swap on rebuild functionality, I can't simply use the name field of the index, since on alternating ...
Frank Rosario's user avatar
0 votes
3 answers
860 views

Sitecore 9.1.1 Azure Search custom index not updating when running rebuild

I'm trying to port an application to Azure Search from Solr. I've got the sitecore indexes working and rebuilding. The documents are being added to the azure search index. However for any custom ...
Richard Forrest's user avatar
2 votes
3 answers
1k views

Custom index field not showing in Azure search

I am trying to use KamSars approach to indexing subcontent (pagecomponents) in my Sitecore 9.2.0 solution. It works fine in my Solr index locally, but when I try to add the two new computed index ...
Hos's user avatar
  • 884
0 votes
0 answers
95 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
PSS's user avatar
  • 607
0 votes
1 answer
124 views

Need to access search keyword in a custom rendering controller in SXA

We are using SXA 1.8 with Sitecore 9. And, we have the requirement to access the search keyword passed in the search-box in one of the custom-renderings. But unfortunately, SXA is appending the search ...
Viswanadh Gupta's user avatar
0 votes
1 answer
123 views

Azure Search queries including too many results due to extra wildcard in fullpath_1 query with space

We are using Azure Search to find items by path. We apply the following search code: var filterPredicate = PredicateBuilder.True<SearchResultItem>(); filterPredicate.And(x => x.Path....
Dan Sinclair's user avatar
  • 5,395
0 votes
1 answer
631 views

Azure search not adding documents from custom index unless renamed

I am having some odd issues with Azure Search in Sitecore 9.2.0, not indexing any documents from my custom index. Locally, when indexing to SOLR there are no problems at all. Background: We use ...
Hos's user avatar
  • 884
0 votes
2 answers
476 views

Rebuilding sitecore_master_index: The property 'property_id_s_t_de' does not exist on type 'search.documentFields'

When we rebuild our sitecore_master_index index, we usually get an error during the rebuild process and the logs show several instances of the below stack trace:  692 12:50:11 ERROR [Index=...
Dan Sinclair's user avatar
  • 5,395
1 vote
1 answer
135 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
Dan Sinclair's user avatar
  • 5,395
1 vote
2 answers
366 views

Azure searches on one Azure CD server are sent as "&search=This_Is_Equal_ConstNode_Return_Nothing"

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
Dan Sinclair's user avatar
  • 5,395