Questions tagged [azure-search]

Anything related to Azure Search: querying, configuring, maintaining, ... Azure (PaaS) replacement for Solr and Lucene.

Filter by
Sorted by
Tagged with
0
votes
0answers
24 views

SXA Map throwing 400 Bad Request

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search. Components added on the page: Map, Location Finder, Search Results (all components have the same search signature). Search Query: ...
0
votes
1answer
26 views

Need to access search keyword in a custom rendering controller in SXA

We are using SXA 1.8 with Sitecore 9. And, we have the requirement to access the search keyword passed in the search-box in one of the custom-renderings. But unfortunately, SXA is appending the search ...
0
votes
1answer
13 views

Azure Search queries including too many results due to extra wildcard in fullpath_1 query with space

We are using Azure Search to find items by path. We apply the following search code: var filterPredicate = PredicateBuilder.True<SearchResultItem>(); filterPredicate.And(x => x.Path....
0
votes
1answer
18 views

Azure search not adding documents from custom index unless renamed

I am having some odd issues with Azure Search in Sitecore 9.2.0, not indexing any documents from my custom index. Locally, when indexing to SOLR there are no problems at all. Background: We use ...
0
votes
2answers
23 views

Rebuilding sitecore_master_index: The property 'property_id_s_t_de' does not exist on type 'search.documentFields'

When we rebuild our sitecore_master_index index, we usually get an error during the rebuild process and the logs show several instances of the below stack trace:  692 12:50:11 ERROR [Index=...
0
votes
1answer
15 views

Warning message: 'GUID' field of 'GUID' item is skipped: field name is missed

In all of our environments, any time there is an index update to our Azure Search indexes, we see the following WARN message logged repeatedly (many thousands of times): 06:11:06 WARN [Index=...
1
vote
2answers
25 views

Azure searches on one Azure CD server are sent as “&search=This_Is_Equal_ConstNode_Return_Nothing”

On one of three CD servers every search we execute is sent to Azure Search like the following: 19660 02:11:05 INFO AzureSearch Query [sitecore_web_index]: &search=...
0
votes
1answer
64 views

Is it possible to make custom computed index field searchable in SXA 1.8

I'm using Sitecore 9.0 with SXA 1.8. I've got a requirement to search PDF names and it's fields including custom fields (e.g. download title field). When I see the Solr index / Azure index, PDF names ...
0
votes
1answer
81 views

Search with dropdown filter based on parent item display name

I am using SXA's search results and dropdown filter to be able to filter items on the search scope by their parent item display name. I have it sort of working by first creating a Computed Index ...
1
vote
1answer
58 views

How to write a custom controller for Sitecore SXA Search Box component?

We are using Sitecore 9.0.2, SXA 1.8.1 and Azure search. The SXA component Search Box works perfectly fine. In our application, we need to show the search results from other application along with ...
0
votes
1answer
46 views

Index names get a number appended

I switched from Solr to Azure search and followed all the steps listed in the blog. I Also renamed the Solr core to lower case with dashes. When I run the xConnectSearchIndexer -rr service the ...
0
votes
0answers
44 views

ERROR Year, Month, and Day parameters describe an un-representable DateTime

We are receiving below errors during Indexing. We are on Sitecore 9 update-2, SXA 1.7.1 and using Azure search. The errors below seems related to SXA fields. Has anyone come across this issue? 10752 ...
1
vote
0answers
23 views

How can the Sitecore search API be extended to support Azure search traffic analytics?

I'm experimenting with adding support for conditionally returning SearchId for Azure search traffic analytics purposes (https://docs.microsoft.com/en-us/azure/search/search-traffic-analytics) as part ...
0
votes
0answers
22 views

How to index sxa tags in azure search and show them in rendering variant of search results [duplicate]

We are using SXA 1.8.1 , Sitecore 9.0.2 and azure search we want to show tags for each item in search results. I created tags under "Tag repository"(under system -> settings) item, the created ...
0
votes
1answer
99 views

Creating a new index in Azure Search for Sitecore 9 Helix structured

Background: I am completely new to Azure Search in general. New to SOLR, Lucene the whole thing. I have a good bit of experience in SQL design for indexes and such, but this seems completely different....
1
vote
1answer
43 views

Date field not showing in Azure Search results

I have a regular date field defined like this: <field type="System.DateTime" fieldName="entry_date" cloudFieldName="entry_date" searchable="NO" retrievable="YES" facetable="YES" filterable="YES" ...
0
votes
1answer
53 views

Resolve PostFailedForSomeDocumentsException exception during indexing

During (manually triggered) indexing of the master database, I get the following exception (stack trace below). Using Sitecore 8.2u7 with SXA 1.7. 27608 10:43:03 ERROR [Index=sitecore_master_index] ...
1
vote
0answers
39 views

SXA checklist filter doesnt return facets with count 0 when used with azure search

I am currently using Sitecore version 9.0.2 and SXA version 1.8.1 Requirement : - In checklist filter, I want to show all the facets irrespective of the results. If for a facet the result is not ...
2
votes
1answer
52 views

Excluding template fields from indexing - difference between documentOptions exclusion vs regular exclusion

I reducing the number of fields which get indexed in my site. I looked at App_Config\Include\Sitecore.ContentSearch.Azure.DefaultIndexConfiguration.config and see the section <configuration <...
5
votes
0answers
98 views

Using Geospatial Features Implemented in SXA with a Custom Search Index - Run-time Error

After manually implementing support for the Edm.GeographyPoint field type (per Is it possible to get Azure Search to support EDM.GeographyPoint?), I was happy to notice an answer on a related question ...
0
votes
2answers
54 views

Techniques and Rules to Eliminating Template fields from Indexing

I am investigating my site's indexing and looking at working around the Azure Search index 1000 field limit (see here Rebuilding Sitecore Core Index on Azure search throwing exceeding index limitation ...
2
votes
1answer
86 views

Sitecore SXA Azure Search Facets Returning 400 Bad Request when there are more than 50 results

I have a search page that is working correctly on my local instance using SOLR, but when we move the page to our AZURE Instance it fails. The AZURE Instance is using AZURE Search instead SOLR. If I ...
2
votes
1answer
54 views

Not finding SXA Rich text rendering content in search results

In our SXA site we make use of the OOTB rich text renderings. I was hoping the content of these would be available in the search results - pointing to the containing page as the result. I notice ...
4
votes
1answer
113 views

Azure Search index including too many fields

Configuration: Sitecore 9.0.2, Azure PaaS As most of us know by now, Azure Search has a hard limit on the number of fields that can be added to an index (1000). To resolve this issue in our ...
0
votes
1answer
55 views

Azure search random behavior running for Sitecore 9.0.2

I am having issue with the Azure Search where I am not getting results from the search index (it is random issue). I’ve verified the configurations of Azure search and computed index fields. Below is ...
0
votes
1answer
49 views

Index stops updating after a search query

I'm using Sitecore 9.0.2 with Azure Search and Solr. I have the weirdest search issue I've seen in a while. Take the following steps: Restart the application (iisreset or similar) Rebuild the search ...
1
vote
3answers
74 views

Sitecore sxa checklist facets in search are not loading when using azure search

I am using SXA 1.8 with Sitecore 9.0.2. I wanted to add a checklist facet to my search, as I am using Azure Search, I added the field to be indexed like below in a custom config file. <include ...
-1
votes
1answer
71 views

Azure Search SwitchOnRebuild returns no results

I have created a separate publishing target (Production). I have created a separate index for this database (sitecore_prod_index). I rebuild my index, and it returns results. I rebuild again, no ...
2
votes
1answer
84 views

Azure Search Indexes are not being added/populated

I am trying to configure azure search in Sitecore. I followed this article to configure it. But when I try to rebuild the indexes, the number of units processed is empty and the indexes are not ...
1
vote
1answer
94 views

Patching Azure Search config files and deploy on Sitecore Azure PaaS

Our application (Sitecore 9.0.2 SXA 1.8) is currently running on Azure PaaS with Azure Search as Search service Recently we ran into this problem of master index exceeding 1000 field Limit we ...
1
vote
1answer
172 views

Sitecore 9.0.2 SXA 1.8 PaaS Azure Search Configuration

This is the first time we working on Azure Search and Sitecore SXA we are facing a problem related to Exception: Sitecore.ContentSearch.Azure.Http.Exceptions.AzureSearchServiceRESTCallException ...
1
vote
0answers
37 views

Response from azure search in portal and on Sitecore UI is different

Environment: Sitecore 9.0.2 XP0 + SXA 1.8.0 + Azure search What I have done: My data is indexed in the index of Azure Search. I have added the search box and search result with custom scope '...
0
votes
1answer
129 views

Azure search with SXA

Environment: SXA 1.8 in Azure PAAS + Azure search What I have: My client has multiple offices and each office has its individual page managed with SXA. The fields on this page include address and ...
4
votes
1answer
81 views

Azure Search duplicate results for multilingual countries in same site with different language versions

We have a multi-lingual site where the group of countries (say for example Asia Region) is hosted in one Site folder. Thus Home, Pages, Settings have different language versions (zh-HK, en-HK, en-AU)...
2
votes
1answer
127 views

Getting the primary Azure Search Index name after index re-build

We are using Azure Search on Sitecore 8.2 update 7 and have enabled switch on rebuild. This is documented here: https://doc.sitecore.com/developers/91/platform-administration-and-architecture/en/zero-...
2
votes
0answers
46 views

Azure Search FilterOn Linq Not Working

I am running Sitecore 9 update 2 on Azure Web App, with Azure Search. I am trying to use the Sitecore Facet Support, that works completely fine with Solr, but having no luck at all with Azure. So my ...
0
votes
0answers
77 views

SXA Custom index not used by Search Results component

Following the SXA documentation Configure SXA indexing, I have created my custom indexes : Then I have created a patch config file for the corresponding index definitions. On a page I use a ...
0
votes
0answers
59 views

Sitecore Azure index is not getting created [duplicate]

We are using sitecore 8.2 update 4 and Azure search service for indexing. We have a custom index and when we rebuild this index, we notice that the items are getting processed and then we get a ...
0
votes
1answer
134 views

Where to check the index that is configured from SXA Search API?

When I request the url https://mydomain/sxa/search/results?q=test, below is the response {"TotalTime":259,"CountTime":211,"QueryTime":38,"Signature":null,"Index":"sitecore_sxa_web_index","Count":0,"...
2
votes
1answer
73 views

Do we need to trigger SXA indexes after cloning a new site?

This is the first time working on SXA Search. We have an SXA site with search in working condition. We cloned a new site from the existing one and using master database for now but the search page is ...
2
votes
1answer
24 views

Set up field copy rules

I need to add custom field to Azure search schema and set up copy field rules to get the values of some other fields and set them as the values of this custom field. I can do it in Solr with Schema ...
1
vote
1answer
54 views

Sitecore Azure indexing logs in CD server when Indexing is triggered from CM server

We are using Sitecore 8.2 update 3 on Azure Iaas. When we trigger Indexing from Control Panel(obviously from CM server), we see the indexing jobs in the logs of CD server. Does this mean that the ...
2
votes
2answers
91 views

How is the name of the primary index name stored when using SwitchOnRebuild in Azure Search?

We are using Azure Search for a custom index and I have SwitchOnRebuild enabled in my config patch. <!-- USE SWITCHONREBUILD Determines if Azure Search provider uses SwitchOnRebuild() ...
3
votes
0answers
77 views

SXA 1.8 Sitecore 9.1 Azure Search field limit reached on default install [duplicate]

In an Azure PaaS XP Single installation of Sitecore 9.1 using Azure Search, I have installed SXA 1.8. This has pushed the Sitecore Master index field count to just over the 1000 field limit in Azure ...
3
votes
1answer
168 views

My index on Content Delivery does not match with CM and is not updating anymore on Azure PAAS - Sitecore 9.0.2

We noticed that our CD environment gave different results from the index compared to the CM environment. We did some more checks and found that the index on CD was also not updating anymore. It did ...
0
votes
1answer
180 views

Auto index rebuild not happening in CD server (Sitecore 9.0 and Azure PaaS)

We have CM and CD servers in Azure PaaS, and Azure search service for indexing the items. After publishing the items from CM to CD auto index rebuild not happening. Content Management index file ...
1
vote
1answer
49 views

SXA scope not working with one specific field in PAAS

I have a SXA search scope which is working, but as soon as I try to extend it with our "Company" field, it fails to find any results. Company is a multilist field. Our steps: Create a search scope ...
2
votes
1answer
131 views

ContentSearch Where vs Filter

When using the ContentSearch API what is the difference in using Where vs Filter and can this have any influence on the results? From the Sitecore documentation : Filtering is similar to using ...
-1
votes
1answer
150 views

Product ID or name is not searchable

I am working on Sitecore commerce 9 update-1. Many customizations are already done till now. For searching I'm using the default Search component. Issue :- Product is not searchable by Product ID/...
1
vote
1answer
272 views

Custom Azure Search Index returns '&search=This_Is_Equal_ConstNode_Return_Nothing' for searches

I have setup an custom Azure Search index in Sitecore 8.2 u7 and was getting no results returned even though I have data in it (I can see the data in the Azure console). Looking in the Sitecore Search ...