6

Sitecore 9 U1

I have stood up a new instance of Habitat Home using this link and this repo. I am not crazy familiar with SXA. I can edit/preview the pages without issue, but when I try and view the site anonymously, I get the below error on every page. Full stack trace here.

It feels like it is related to the site config. I have updated and tinkered with it in SXA and gone as far as creating a traditional site config via a patch file, but no go.

Any thoughts?

Server Error in '/' Application.
Invalid item path in XA.Foundation.Presentation.PartialDesignDynamicPlaceholderRendering
Description: An unhandled exception occurred. 

Exception Details: System.Configuration.ConfigurationErrorsException: Invalid item path in XA.Foundation.Presentation.PartialDesignDynamicPlaceholderRendering

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 


[ConfigurationErrorsException: Invalid item path in XA.Foundation.Presentation.PartialDesignDynamicPlaceholderRendering]
   Sitecore.XA.Foundation.Presentation.Services.LayoutXmlService.GetPartialDesignRenderingItem(Item item) +238
   Sitecore.XA.Foundation.Presentation.Services.LayoutXmlService.CreateWrapperElement(Item item, String partialDesignSignature) +354
   Sitecore.XA.Foundation.Presentation.Services.LayoutXmlService.GetFromField(Item item) +2170
   Sitecore.XA.Foundation.Presentation.Services.LayoutXmlService.b__3_0(Item s) +65
   System.Linq.WhereSelectEnumerableIterator`2.MoveNext() +223
   System.Linq.d__17`2.MoveNext() +150
   System.Collections.Generic.List`1.InsertRange(Int32 index, IEnumerable`1 collection) +454
   Sitecore.XA.Foundation.Presentation.Services.LayoutXmlService.GetRenderings(Item contextItem, Item designItem) +149
   Sitecore.XA.Foundation.Presentation.Pipelines.GetXmlBasedLayoutDefinition.AddPartialDesignsRenderings.Process(GetXmlBasedLayoutDefinitionArgs args) +679
   (Object , Object[] ) +74
  • I take it you have tried the obvious, and published everything? – jammykam Jul 6 '18 at 3:30
  • @jammykam yup, published, rebuilt all indexes, iisreset, all the normal stuff. Whenever I see editor works, anonymous doesn't. Its always the site config. But SXA has the custom site provider. Not sure how to debug it. I remember at some point there was an admin section that would list the sites configured. – Chris Auer Jul 6 '18 at 3:37
  • So did you create the Site using SXA way or you go with traditional side definition in the config file (it's not 100% clear to me from your post)? – Dawid Rutkowski Jul 6 '18 at 6:30
  • @DawidRutkowski it was created via unicorn sync. – Chris Auer Jul 6 '18 at 13:16
  • @ChrisAuer So you were saying about publishing everything... :trollface: – jammykam Jul 6 '18 at 14:55
6

This exception happens if the following item cannot be found

ID:

{455948A7-9860-4312-B818-994E723E8B9A}

Path:

/sitecore/layout/Renderings/Foundation/Experience Accelerator/Dynamic Placeholders/PartialDesign Dynamic Placeholder

Setting in the config where the ID comes from.

<setting name="XA.Foundation.Presentation.PartialDesignDynamicPlaceholderRendering" value="{455948A7-9860-4312-B818-994E723E8B9A}" patch:source="Sitecore.XA.Foundation.Presentation.config"/>

Check if you got this rendering in your database because it looks like it is not there. Or at least not in a database of your context item (during the request)

| improve this answer | |
  • This item was in the master DB and not web. I had to republish it to get it into the web DB. But you are right, this solved that error. Thanks. – Chris Auer Jul 6 '18 at 13:16
  • 3
    @ChrisAuer That was the first question under your post - did you published everything:D – Dawid Rutkowski Jul 6 '18 at 13:43
  • I know I know :). I just did think of a full republish was needed. Still fighting with this site. – Chris Auer Jul 6 '18 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.