0

I have been working with Sitecore version 8.2, with three to four sites in one instance. Everything work fine, but in logs the following errors are seen.

 ERROR Application error.
Exception: System.Web.HttpException
Message: Exception of type 'System.Web.HttpException' was thrown.
Source: System.Web.WebPages
   at System.Web.WebPages.WebPageRoute.DoPostResolveRequestCache(HttpContextBase context)
   at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) 

Just wondering how this error occurs on the site and none of the functionality is affected. Please provide an detailed explanation regarding the same

  • We use not Sitecore but ASP.NET WebPages. We find that the same error occurs about every 21 minutes in our environment, though we don't know the reason. – nabe Oct 9 '18 at 1:44
2

about every 21 minutes

The application pool in our environment was

  • General/Start Mode=AlwaysRunning
  • Process Model/Idle Time-out(minutes)=20

We had changed the time-out to 1, now the error occurs about every 2 minutes.


We logged "Request.AppRelativeCurrentExecutionFilePath" when the error occurred.

We found the wrong setting in our environment. (web.config / configuration / system.webServer / applicationInitialization)

Correct)<add initializationPage="foo/bar.cshtml" />

Wrong)<add initializationPage="~/foo/bar.cshtml" />

The wrong setting caused the wrong path. (~/~/foo/bar.cshtml)

The correct setting resolved the error in our environment.

| improve this answer | |
  • Will check this and let you know the results – rams Oct 9 '18 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.