0

I am using Sitecore 8.1 Update 3. According to Sitecore installation manual, with mongoDB version 3.0.12. The other day, when the connection of mongoDB out of order, the using connection pool exceeded 100 and a connection timeout error occurred. Looking at the site of Mongo.driver.DLL, I found that version 1.X.X has the above problem and it is solved with version 2.X.X. And I Know that Sitecore also changed Mongo.driver.DLL to version 2.4.4 for 8.2 Update 5 for the same reason.

A question (1) Can I use Mongo.driver.DLL 2.4.4 with Sitecore 8.1 Update 3? (2) If so, how do I change the setting in web.config?

I am pleased that you can borrow the knowledge of everyone.

  • Welcome to Sitecore Stack Exchange! I wish I had better news for you! – Pete Navarra Dec 4 '18 at 4:00
2

In a nutshell:

1) No.

Sitecore 8.1 does not support the version of the driver that you are seeking to use. It is not possible to upgrade the driver in Sitecore 8.1 either because of the amount of API code that Sitecore uses in the older version of the driver.

To take advantage of Mongo.Driver.DLL 2.4.4, you must upgrade to Sitecore 8.2 Update 5 as Sitecore released support of the Mongo 2.4.4 driver in this update.

This is included in the Release Notes for Sitcore 8.2 Update 5.

Mongo driver has been upgraded to version 2.4.4, it is possible to reduce connection open timeout now. TFS No. 151475

| improve this answer | |
  • Thank you Peta. I understand that Mongo.driver.DLL 2. XX is still not available in SC 8.1. I thought that I could use it somehow but I will give up. I'll consider upgrading to SC 8.2 UPD 5 or later. – Kato Tetsuya Dec 4 '18 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.