2

When running the installation script for Sitecore Experience Commerce 9.1 I am getting the following error:

Install-SitecoreConfiguration : The remote server returned an error: (500) Internal Server Error

This occurs during the BootStrapCommerceServices step of the installation. Directly after logging:

PUT https://commerceshops.sc9.qa/commerceops/Bootstrap() with 0-byte

Below is the error I get in the shops log file, it doesn't mean anything to me and I have not be able to find any relevant information on the error, but perhaps someone recognizes it:

ERROR Message=SQL.GetDBVersion.Fail: Environment='GlobalEnvironment'|Message='Could not find stored procedure 'sp_CommerceDBVersionGet'.'|Number='2812'|Procedure=''|Line='1'|CorrelationId=3a39ea7b355848989241178fab405522|StackTace=   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
   at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
   at System.Data.SqlClient.SqlDataReader.TryConsumeMetaData()
   at System.Data.SqlClient.SqlDataReader.get_MetaData()
   at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString, Boolean isInternal, Boolean forDescribeParameterEncryption, Boolean shouldCacheForAlwaysEncrypted)
   at System.Data.SqlClient.SqlCommand.CompleteAsyncExecuteReader(Boolean isInternal, Boolean forDescribeParameterEncryption)
   at System.Data.SqlClient.SqlCommand.InternalEndExecuteReader(IAsyncResult asyncResult, String endMethod, Boolean isInternal)
   at System.Data.SqlClient.SqlCommand.EndExecuteReaderInternal(IAsyncResult asyncResult)
   at System.Data.SqlClient.SqlCommand.EndExecuteReaderAsync(IAsyncResult asyncResult)
   at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)

Based on various blog post regarding errors in the commerce 9 installation I change the connection string SQL server name to {MACHINE}\\SQLEXPRESS in the following files:

  • \SitecoreIdentityServer\wwwroot\appsettings.json
  • \CommerceShops_Sc9\wwwroot\bootstrap\Global.json
  • \CommerceOps_Sc9\wwwroot\bootstrap\Global.json
  • \CommerceMinions_Sc9\wwwroot\bootstrap\Global.json
  • \CommerceAuthoring_Sc9\wwwroot\bootstrap\Global.json
  • \CommerceShops_Sc9\wwwroot\data\Environments\Plugin.SQL.PolicySet-1.0.0.json
  • \CommerceShops_Sc9\wwwroot\data\Environments\PlugIn.Habitat.CommerceAuthoring-1.0.0.json
  • \CommerceShops_Sc9\wwwroot\data\Environments\PlugIn.AdventureWorks.CommerceAuthoring-1.0.0.json

In the Global.json files I even changed the second occurrence of the database property from SitecoreCommerce_Global to SitecoreCommerce9_Global.

I have also attempted to add a username and password to both the connection string in appsettings.json and the Global.json files.

None of these changes have helped. Is there something else that I'm missing? Any help would be greatly appreciated!

0

The problem was that I had previously installed a different version of Sitecore Experience Commerce. Removing the old installation (IIS sites and app pools, directories, databases and solr cores), and re-running the script fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.