1

I've added a placeholder to a rendering variant.

When I use that variant on a page, I click on the add item button, and I get the default window with all renderings available. I have then added a placeholder setting item, and put the key in the placeholder key of the placeholder in the variant. I still see all renderings when I go to add an item.

One issue I noticed is if I try to edit the placeholder setting in the experience editor it's not picking up the correct item due to the -1-1 that are getting added to the placeholder setting

placeholdersettingedit

Does anyone have any idea what I need to do to correct this?

Here is my placeholder setting

placeholdersetting

And here is my placeholder in the variant

renderingvariant

I've tried this with and without the * to indicate a dynamic placeholder.

  • Can you update your question with screenshot of actual placeholder settings found under site/Placeholder Settings/featuredvideo? – Peter Procházka Jun 5 at 4:59
  • @PeterProcházka sorry for forgetting about these earlier, I've added them now. – craig41bl Jun 5 at 14:21
  • Did you try putting featuredvideo* in the placeholder key in the placeholder setting? That should work. – Gatogordo Jun 5 at 15:45
  • @Gatogordo yep, that did it. I could have sworn I'd tried that configuration, but evidently I hadn't, thank you. – craig41bl Jun 5 at 16:17
  • I'll add it as answer as soon as I get back at my laptop.. – Gatogordo Jun 5 at 16:29
1

You should put featurevideo* in the placeholder key of the placeholder setting.

The placeholders in the rendering variant are dynamic, which explains the -1-1 addition to the key you provided in the variant. To capture those dynamic additions, you need to use wildcards in the placeholder key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.