4

I have a recently upgraded 8.1 Sitecore instance with EXM 3.3 installed. When I try to create a new regular Email Campaign I get the following screen. Am I doing something wrong? Is something not installed correctly or configured correctly? All I see is Import HTML.

enter image description here

  • Any errors in your log files? – Richard Seal Oct 27 '16 at 15:56
  • No errors in the main log file. The only thing in the EXM log file is the following: 1568 11:38:20 INFO The configured default global opt-out list does not exist. A new list has been created: /sitecore/system/List Manager/All Lists/E-mail Campaign Manager/System/Common Global Opt-out 1568 11:38:20 INFO The manager root item 'Email Campaign' ({0712383D-F27F-4847-91C9-FC74DF5CA9AF}) is not referencing a valid global opt-out list and has been changed to the configured default. – Corey Burnett Oct 27 '16 at 16:02
  • Any errors in the browser console? – Jacob Nielsen Oct 27 '16 at 17:01
  • No errors in the browser console either. – Corey Burnett Oct 27 '16 at 17:04
4

In EXM, the reason this list is blank is because the Default item for One-Time Messages has not been associated with any Message Templates.


Background Information

For Each EXM Manager Root, there are three types of Messages that can be sent out.

  • One Time Messages
  • Subscription Messages
  • Triggered Messages

Under a Single EXM Manager Root, it looks like this:

enter image description here

The red arrow is pointing to the Default setting item for the One Time Messages. Open the item up in Content Editor to review settings for this item.

Of particular interest is the Insert Option field on this item.

enter image description here

EXM uses the Insert Options field of this item to store which Message Templates for the specific EXM Manager Root, should display in the Create Screen.

In the above example, only one message shows up. When I go to the Create Screen, I see one message.

enter image description here

When I add a new Message Template (located in the /sitecore/templates/branches folder:

enter image description here

The resultant Create Message option dialog looks like:

enter image description here


Why Aren't The Default EXM Insert Options Shown?

For some reason, during the upgrade process, the default message create options were erased from this object. Simply add the default ones back in, if you'd like to use them. You can find them in the branch templates:

enter image description here


Gotchas

  • If dealing with multiple EXM Manager Root's, besure you are adjusting the right manager root, otherwise you'll pull your hair out for 2 hours like I did while writing this answer, just to realize that I had the wrong Manager Root selected in EXM. =) Opps.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.