0

I'm trying to sync Unicorn (4.1.1) on Habitat 1.8 (Sitecore 9.2). I'm running Visual Studio 2019 as Admin and PowerShell execution policy is for CurrentUser = Bypass and for LocalMachine = Unrestricted.

Also it did sync "Project.Habitat.Website" project after this sync it throws an error.

Project.Habitat.Website role sync complete.
Completed in 261ms.
****ERROR OCCURRED****
Error: Unicorn Sync to http://habitat.dev.local/unicorn.aspx?verb=Sync&configuration=&skipTransparentConfigs=0 returned an 
Error: error. See the preceding log for details.
At C:\Projects\Github\habitat18sc920\scripts\Unicorn\Unicorn.psm1:66 char:3
Error: +         throw "Unicorn $Verb to $url returned an error. See the prece ...
Error: +         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Error:     + CategoryInfo          : OperationStopped: (Unicorn Sync to...og for details.:String) [], RuntimeException
    + FullyQualifiedErrorId : Unicorn Sync to http://habitat.dev.local/unicorn.aspx?verb=Sync&configuration=&skipTrans 
   parentConfigs=0 returned an error. See the preceding log for details.

C:\Projects\Github\habitat18sc920\scripts\unicorn.js:44
    if (err !== null) throw err;
                      ^
Error: Command failed: powershell -executionpolicy unrestricted "C:\Projects\Github\habitat18sc920\scripts/Unicorn/./Sync.ps1 -secret 749CABBC85EAD20CE55E2C6066F1BE375D2115696C8A8B24DB6ED1FD60613086 -url http://habitat.dev.local/unicorn.aspx"
Unicorn Sync to http://habitat.dev.local/unicorn.aspx?verb=Sync&configuration=&skipTransparentConfigs=0 returned an 
error. See the preceding log for details.
At C:\Projects\Github\habitat18sc920\scripts\Unicorn\Unicorn.psm1:66 char:3
+         throw "Unicorn $Verb to $url returned an error. See the prece ...
+         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: (Unicorn Sync to...og for details.:String) [], RuntimeException
    + FullyQualifiedErrorId : Unicorn Sync to http://habitat.dev.local/unicorn.aspx?verb=Sync&configuration=&skipTrans 
   parentConfigs=0 returned an error. See the preceding log for details.

    at ChildProcess.exithandler (child_process.js:294:12)
    at ChildProcess.emit (events.js:182:13)
    at maybeClose (internal/child_process.js:962:16)
    at Socket.stream.socket.on (internal/child_process.js:381:11)
    at Socket.emit (events.js:182:13)
    at Pipe._handle.close (net.js:610:12)

closed as off-topic by Mark Cassidy Aug 19 at 8:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question was caused by a problem that can no longer be reproduced or a simple typographical error. While similar questions may be on-topic here, this one was resolved in a manner unlikely to help future readers. This can often be avoided by identifying and closely inspecting the shortest program necessary to reproduce the problem before posting." – Mark Cassidy
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Run it directly, on /unicorn.aspx - the web console will tell you what's wrong. – Mark Cassidy Aug 17 at 23:29
  • Thank you @MarkCassidy – Ercan Polat Aug 19 at 0:32
  • Sitecore Solr, Sitecore Unicorn, Sitecore Azure, Coveo,.... These and many other technologies are tied directly to Sitecore. Where should these questions to be asked? Do you think we should have a new Stack Exchange site for each technology. In my opinion it is Ok to ask these questions on this site, as long as is directly related to Sitecore. @MarkCassidy – Ercan Polat Aug 20 at 14:34
  • 1
    Of course they are. The question was closed because it is unuseful for our audience here. You fixed the problem; you don't know what you did to fix it; and it's not a systemic problem - rather it's a problem specific to your machine/solution/installation. – Mark Cassidy Aug 20 at 14:40
  • Thank you for the clarification. You are right, it makes sense. @MarkCassidy – Ercan Polat Aug 20 at 16:50
0
  1. I did actually use the Unicorn.aspx file and serialized all projects, without any problem.
  2. After that I did run the "gulp/default" task and the problem was solved.
  3. I'm still not sure what the reason was for this error however @MarkCassidy suggestion solved the issue.

Thank you @MarkCassidy

Not the answer you're looking for? Browse other questions tagged or ask your own question.