In Sitecore 9.1.1

I have some PDF documents in the media library that i've "unpublished" (unchecked the publishable publish setting)

Then smart-publish parent folder, subitems and all languages.

If I use the exact URL to the PDF it still downloads. I don't seem to be able to get rid of the items. It's also still coming up on Google results.

I have...

  1. confirmed that the item does NOT exist in web database.
  2. deleted mediacache folder.
  3. cleared cache in /admins/cache.aspx.
  4. purged all cloudflare cache.
  5. Rebuilt link database.
  6. confirmed site definition attribute "database=web" and not master.

I'm out of ideas. What can I do next?

Thank you

  • 2
    Did you clear your browser cache? Browsers will grab media from cache without ever involving the server, if they think they can.
    – Mark Cassidy
    Nov 19, 2020 at 16:09
  • CDN cache the document? Nov 20, 2020 at 2:28
  • you can also submit the url using google webmaster tools to purge the url from Google indexes
    – Abhay Dhar
    Nov 23, 2020 at 5:01

2 Answers 2


If media is cached by Cloudflare, check cloudlare headers cf-cache-status, cf-ray when accessing media url in a browser. If the media is HIT then is still in Cloudflare cache. If you want to cache Sitecore media in CDN, you should set media to always append revision.

      <setting name="Media.AlwaysAppendRevision" set:value="true"/>

Try hitting the URL with a random url parameter and see if it still shows up. If it does, it's coming from Sitecore. If it doesn't, it is coming from one of them caches. Most likely culprit is Cloudflare or Browser as mentioned above

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.