0

I'm facing one issue while catalogs are getting created to Sitecore. I have created a new catalog in commerce with sellable items for languages en-CA, fr-CA. I have verified the content from biz tool and I can confirm that the products are created in proper language versions. But when I check the catalogs under my storefront on Sitecore, I can see items are created in en-US version instead of en-CA and fr-CA. In my instance, I have other storefronts supporting en-US. All the languages are added in Sitecore and I checked the language set mapped to the storefront is having the en-CA selected. enter image description here

enter image description here

I tried, delete, update data templates, clear cache from sitecore, redis.

Any idea, where I'm missing something.

1

1 Answer 1

1

Please check the DefaultShopName on Sitecore.Commerce.Engine.Connect.config.

If your site is not a multisite (Only 1 Catalog & 1 Shop), you can set the default ShopName as your Storefront ShopName. Catalog Items crawler will pick the associated Language Set of the storefront and index all the items with configured language(s).

But this will not work for multi-branded & multilingual sites as each site may have different language and different catalogs associated. So configuring specific ShopName in this case, crawler will take the language set of this shop and do the index.

Setting up DefaultShopName CommerceEngineDefaultStorefront on Sitecore.Commerce.Engine.Connect.config should fix your issue.

Updating DefaultShopName as CommerceEngineDefaultStorefront will index all languages and you could see all available languages on your catalog items.

Refer this blog for more information, https://doc.sitecore.com/xp/en/developers/91/sitecore-experience-commerce/configure-the-language-set-for-catalog-item-indexing.html

1
  • This worked more me, in my case, I have a different shopname marked and default which have only en-us language. changing that to CommerceEngineDefaultStorefront resolved the issue
    – Jojo
    Dec 6, 2021 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.