2

I am trying to create an application for sitecore 10 JSS with react. But I am getting the error

jss create is not supported from JSS CLI version 20.0.0 

can you please suggest.

1 Answer 1

4

I think with the latest version of JSS, you need to use this command.

npx create-sitecore-jss

This command scaffolds a JSS application based on the latest version of JSS templates

Follow this article for more details.

https://doc.sitecore.com/xp/en/developers/hd/200/sitecore-headless-development/create-a-jss-project-for-the-latest-versions-of-jss-and-sitecore.html

To create an application based on an older version of JSS and Sitecore, you need to use this.

jss create my-jss-app react --branch release/<version>

Follow this article for more details.

https://doc.sitecore.com/xp/en/developers/hd/200/sitecore-headless-development/create-a-jss-app-for-an-older-version-of-sitecore.html

1
  • Did it solve your issue? Jun 6, 2022 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.