We have installed Sitecore(9.0.1) instance in Azure Web App , we often facing Sitecore CM slowness as number users are more or number input requests are more and we have decide to go with multiple CM server one is for Authoring and Other one for Publishing. By scaling CM instance we may reduce the traffic.

Please suggest how can we setup multiple CM instances in Azure Web App?

2 Answers 2


If you want to achieve a clear separation of concerns and delegate the Publishing responsibility to another CM instance then I would recommend to configure a Content Publishing (CP) service that can be installed as an Azure Application Service in addition to your existing CM instance to offload it.

CP service acts as a replacement for the Sitecore publishing methods that are part of the Content Management role and increases publishing throughput, reduces the amount of time spent publishing large volumes of items, and offers greater data consistency and reliability.

Please visit the Publishing Service download page for documentation about setup and configuration, and also check the CP compatibility table with your Sitecore version here.

For development needs you can simply run the Publishing role as a console application.

  • @Orlova, Have you implemented Authoring Sitecore instance for any one of your projects?
    – Reddy
    Aug 8, 2022 at 8:48

You need to use the Sitecore Azure Toolkit (SAT) to install the Content Management role, you can refer to the installation guide for your Sitecore version (9.0.1).

See the below scaling options for CM role - enter image description here

While installtion the separate CM, please make sure to consider below points -

NOTE - The Publishing.PublishingInstance setting is only relevant when you are using the built-in publishing methods in the Content Management role. It is not relevant if you are using the optional Content Publishing service.

  • In the /Web.config file, set the validationKey and the decryptionKey attributes of the /configuration/system.web/machineKey setting to a non-auto generated value. Ensure that the value is the same on all the Sitecore instances within the environment and that the IsolateApps modifier is not present in either value.

  • On all but one instance, create a patch file that disables Scheduled Task processing:

      <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
        <agent name="Core_Database_Agent">
          <patch:delete />
        <agent name="Master_Database_Agent">
          <patch:delete />
  • Shared session state is not supported on Content Management (CM) servers and you have to use a load balancer to use sticky session.

  • If you have multiple CM instances, you must set up a dedicated Reporting Service instance.

References -

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.