2

I restored databases from production to Test environment. After that index's are not working with OnPublishEnd strategy. Could you please help me.

I have truncated History,EventQueue and PublishingQueue tables. I confirmed Event Queues enabled.

Whenever publish item it gets update on web db but not showing on search results.

I have seen below message in logs.

Event Queue is empty. Incremental update returns

  • 2
    Have you tried to rebuild indexes manually first? – Marek Musielak Feb 7 '17 at 13:13
  • Yes, Manual rebuild working fine. – durgar Feb 7 '17 at 13:22
  • eventqueue processinterval updated from 2 sec to 30 sec resolved my issue. – durgar Feb 9 '17 at 5:24
2

Here is a link with a detailed explanation on indexing strategies and best practices.

Considering the description of the issue you are saying you should always, when copying over indexes from one server to the other make sure that the new server has the indexed rebuilt at least once.

If that doesn't address your issue you can use the powershell module or the Luke tool to review the content of the indexes and compare them. For example you have the content you want on the master but not on the web indexes. That most likely means you are having an indexing issue(considering that content is properly published and indexed but still doesn't show). You might also want to check on the logs folders the publishing logs. They show you what's going on. For example if Sitecore skipped the publishing you can easily determine it by looking at those logs. Hope this helps you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.