Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [indexing]

Questions about indexes in Sitecore (standard or custom) in general. For questions that apply to Lucene or Solr, use the appropriate tags.

2
votes
1answer
57 views

How to add externally stored PDF documents to my existing custom index

using Sitecore 8.2 update 4 and SOLR 6.6.0. Currently using a custom crawler to index database records. I have a requirement to now index the actual pdf content the database will house a http://path/...
3
votes
0answers
32 views

Is it possible to run a CD deployment without any indexing tools in place?

When deploying your application into e.g. Azure there are lots of configurations that allow adding or removing features. A good example would be XP vs XM. We have the situation where we don't use ...
2
votes
1answer
38 views

How to ensure that sitecore_web_index is up to date on CD server

I run Lucene indexes on Sitecore 8.1. I have a custom index that is being generated correctly (on sitecore_web_index) on the CM server, but this change is not reflected on the CD server. Further ...
0
votes
1answer
47 views

How Sitecore index primary and secondary sync in SolrCloud?

Let me start of by describing my current set up. I am currently having Sitecore 8.2 update 6 running with Solr Cloud 5.5.1 as a search engine. I have 1 CM and 2 CDs. Solr Cloud is running on 5 servers ...
2
votes
2answers
45 views

Query Index Count in Custom .NET Page

I am building a custom .NET Page and I need to query the total count of items in each Sitecore index (backend is Solr). I have not been able to find any "hooks" or documentation of the Sitecore API to ...
3
votes
0answers
60 views

Sitecore Index_Update Job Performance

We just updated from Sitecore 8.2 Update 4 to Update 7 and we've started seeing some strange behavior when publishing new items. The issue presents itself in that it takes awhile for newly created ...
1
vote
1answer
27 views

Rebuild Index progress dialog shows Sitecore Desktop

In Sitecore 8.2 Update 3, when I try and rebuild an index from inside the content editor (From the Developer ribbon) when the dialog opens that should be a progress bar showing the rebuilding progress,...
0
votes
1answer
38 views

Computed Index Field for TreeList in SOLR [duplicate]

as treelist values is being indexed in solr as IDs so I needed to create a computed index field for it to read the names, as follows namespace TAMM.SXA.Feature.ServiceDetails.ComputedIndexFields { ...
5
votes
1answer
57 views

Sitecore indexing commit policy Executor

There are several sitecore indexing commit policy executor like Sitecore.ContentSearch.TimeIntervalCommitPolicy and Sitecore.ContentSearch.ModificationCountCommitPolicy I want to know the ...
0
votes
0answers
48 views

Not able to reindex Sitecore Azure indexes

I am using Sitecore 8.2 Update 3, Azure Paas. Did anyone encounter same issue as below and any suggestions will be helpful? The error stack trace is as below : 5092 11:01:12 WARN [Index=...
0
votes
1answer
22 views

How to add charFilter to Solr Managed Schema from Sitecore 9?

I need to add a charFilter to the Solr managed schema. I'm using Solr Cloud 6.6 and Sitecore 9.0.1. Sitecore uses a SchemaPopulateHelper class that generates xml updates to the managed schema. It ...
3
votes
1answer
77 views

Remove custom templates from sitecore master index

We are using Sitecore 8.2 update 3 and azure search for indexing.Azure search has limitation of 1000 fields so what we are planning to do is to remove the custom templates from the ...
1
vote
1answer
36 views

Excluding fields with same name from indexing

I want to exclude two fields with the same name from indexing. Can I have two entries in the DefaultIndexConfiguration.config file in the exclude list or is there any other way ? Example below where ...
0
votes
1answer
93 views

Rebuild of Indexes in Sitecore Commerce 9.0.2 fails with null reference error

I am trying to rebuild all my Indexes after the Sitecore commerce 9.0.2 setup but the rebuild failed with error as below The logs I found from the CommerceAuthoring_sc9 says 4 00:44:26 ERROR ...
0
votes
1answer
22 views

Does it matter Sitecore CM connect to Solr Cloud leader vs follower?

We currently have our Solr Cloud with zookeeper and for front with load balance (Solr Prd1 and Prd2). CM is connecting to Solr Prd1 (leader) and CDs are connecting to Solr load balance. Questions: ...
0
votes
0answers
108 views

SOLR search index not updating

I've renamed fields on a Sitecore template from uuid to uuid2, but for some records the solr index contains items with the field name uuid (in SOLR admin). I've populated my SOLR schemas again and ...
2
votes
1answer
109 views

Config patch/hack to temporarily disable index update

Is there some easy config patch or hack I could make which would disable all indexing activities? I want to do this for things like package installation and also deletion of large content branches ...
3
votes
1answer
189 views

Programmatically adding items to a custom Solr Index

I'm trying to add some items to a custom Sitecore Solr index Programmatically via the Sitecore Content Search APIs. The items I will add won't reside in Sitecore so the code below is just a test for ...
0
votes
0answers
31 views

Prices of products in Commerce Server with comma separator decimal values not Indexed properly

In the Commerce Server Catalog Manager the Prices of Products are shown with comma separated(12,33) rather than point or decimal separated(12.33). When this get indexed in Solr we the prices are ...
1
vote
1answer
151 views

SwitchOnRebuild with SolrCloud not working

We are running Sitecore 9.0.0 (Initial Release) on Azure with SolrCloud (6.6.2) and getting close to go-live. We are using Sitecore's SwitchOnRebuild functionality for indexing so that the indexes ...
0
votes
0answers
222 views

Solr index timeout out error

I have the following exception when running the Solr search index. It was running till 23000 records. After that its getting failed and got the following exception. Job started: ...
4
votes
3answers
204 views

Getting duplicate data on server. Indexing issue?

Using Sitecore 9.0.1 and DEF 2.0.1, I have a pipeline which reads from an API and then resolves matching Sitecore items using the standard ResolveSitecoreItemStepProcessor and ...
1
vote
1answer
137 views

Exception GetCatalogEntityLanguages during the rebuild of sitecore_master_index (Sitecore 9.0.1)

We were able to import our products from Sitecore Commerce to the Sitecore CMS (saved as virtual items), and I would like to search for these products using the Sitecore Search. So I rebuild the ...
3
votes
1answer
186 views

Sitecore datetimecollection computed field issue

We've solr configured for our 8.2 solution. Recently, a new computed field has been added to the schema. This field is a datetimecollection field which has list of datetimes. Here is the code for it....
1
vote
1answer
116 views

Sitecore Date type Solr indexing In UTC - How to perform solr search

I have a date field in the template. It's value is set to 4/8/2018. However, when I see the item's raw value, Sitecore converts it into UTC and stores it like 20180407T183000Z. The same value is ...
2
votes
0answers
179 views

Sitecore-Core-Index rebuild at Azure Search for Sitecore 9.0.1 PaaS fails

I have deployed Sitecore 9.0.1 XP Scaled in Azure PaaS (default, no customization). It is used self-signed certificate and configured with allowInvalidClientCertificates="true" in azuredeploy....
0
votes
1answer
269 views

Rebuilding custom index not working at all

I took backup of running site and setup in my development environment, when I rebuild custom indexes on staging (CM) under data/indexs folder I can see all files are updated but on production (CD) ...
1
vote
1answer
307 views

Rebuilding web index does not bring the published items

I took a backup from the server and setup the site on my local development environment. (by backup, I mean I took backup of all databases) I set up staging(CM) and Production(CD) on my local ...
2
votes
1answer
54 views

Don't Index An Item In DEF Until All Items Have Been Added

I'm creating a large number of items using Data Exchange Framework (DEF). It looks like the items are being indexed one at a time when created/updated. I have a pipeline step that indexes a subtree of ...
0
votes
1answer
69 views

Index Subtree Of Items For A Specific Index

Is there a way to index a subtree of items for one specific index in code? I know there's the reindex tree button but that reindexes the subtree for all indexes the items are in. I don't see a good ...
0
votes
1answer
268 views

Error while rebuilding the search index on Sitecore 8.2 and Solr 6.6.1

We are able to successfully build all the indexes for the first time except sitecore_master_index, sitecore_web_index and Sitecore_core_index And when trying to rebuild sitecore_master_index for the ...
0
votes
1answer
88 views

Sitecore 8.2 Lucene Indexes Syncing Between CD and CM Servers

We have a custom Lucene index configured on our Content Management and Content Delivery server. The rebuild strategies on the index are <strategies hint="list:AddStrategy"> <strategy ref="...
0
votes
1answer
102 views

sitecore_web_index corrupted on Content Delivery server [closed]

What does the Lucene sitecore_web_index do on the Content Delivery server? How can it become corrupted?
0
votes
0answers
169 views

Record count in Index value in Sitecore not matching with SOLR custom core index record count

We created a custom index in SOLR to implement search data from custom database using custom crawler. The Index is successfully build for custom data and around 5k documents processed but while ...
1
vote
0answers
465 views

The remote server returned an error: (400) Bad Request Error while building the custom index in SOLR 5.1

We have created a custom Itembuket_community and rebuliding the index. while Rebuilding the index, getting follwoing error Job started: Index_Update_IndexName=sitecore_Community_index|#Exception: ...
0
votes
0answers
69 views

PowerShell find-item doesn't return values

I'm currently using find-item on Sitecore PowerShell Find-Item -Index sitecore_master_index -Criteria @{Filter = "Equals"; Field = "recipe id"; Value = "Recipe_Lambada"}, @{Filter = "DescendantOf"; ...
3
votes
1answer
193 views

No Indexes showing in Index Manager on Azure CM AppService

We have created our Sitecore production environment (Sitrecore 8.2 Update 5, EXM + XDB Cloud) using ARM templates. This means we have CM, CD, Reporting, Processing and DDS (Data Distribution Server) ...
0
votes
0answers
152 views

Text search case sensitive when using StandardAnalyzerWithStemming search analyzer.

I changed my _content field to use Sitecore's StandardAnalyzerWithStemming so that I can search for plural words as well and the singular. But now the search phrases are case sensitive. If I use Parks,...
5
votes
1answer
267 views

How to configure Sitecore to index “everything but something” or “nothing but something”?

In one of the video from "Search Driven" module of Sitecore 9.0 Essential for Developers e-learning, the speaker says "You can configure Sitecore to index everything but something or nothing but ...
3
votes
1answer
98 views

What are some methods for indexing and searching content from multiple sites? [closed]

Pretend you have a small client that is on Sitecore 8.2 on-premise (virtual servers). Traffic is pretty light, and they get away with using just 2 servers (1 DB and 1 Web). Needless to say budget is ...
6
votes
1answer
319 views

Is it possible to get Azure Search to support EDM.GeographyPoint?

With regard to spatial searching capabilities of Azure Search in Sitecore. How do you go about customising your index configuration so that you can perform spatial searching using the OData geospatial ...
2
votes
1answer
114 views

How to correctly process index dependencies for correct language?

I am updating index dependencies as mentioned in Sitecore Full Content Search where we are using GetDatasourceDependencies. Now, the issue is that this works fine for the English language, but, ...
2
votes
2answers
176 views

Sitecore HTML Indexing

We have custom indexer which indexes all the RTF Data in present in content tree and this indexed RTF Data can have Div's ,breaker Tags and anchor tags. When we get search result out from Solr we ...
3
votes
1answer
208 views

Sitecore Azure Search - There is no appropriate index for /sitecore - {11111111-1111-1111-1111-111111111111}

I have a Sitecore 9.0.1 instance running in Azure and uses Azure Search. My search index is working as far as I know and can be rebuilt. Earlier this week, I hit the problem with Sitecore Azure ...
1
vote
0answers
63 views

Search results error on single server setup

We have a client site that is spread across 2 cd's and 1 cm which we have migrated to a single server instance for QA purposes. The production site has a public address for the cd's and a private ...
3
votes
0answers
326 views

Error with indexWorker process in Sitecore 9 xConnect with Solr 6.6.2

I am running Sitecore 9 with Solr 6.6.2 and I am seeing lot of error in the IndexWorker logs in Sitecore xConnect as below: 018-02-21 16:16:13.686 +10:00 [Error] An error occured. System.Net.Http....
0
votes
3answers
165 views

Lucene Search Indexing Issue

In a project, I have used Lucene Search. Earlier everything was working fine. But from last few days I am facing issue in getting items through search on production server. I performed Index ...
6
votes
1answer
612 views

How do you programmatically exclude an item from being indexed?

We would like to exclude items from being indexed. Ideally, we want this control to be within Sitecore so that as new pages get created, content authors can determine whether to index them as they ...
1
vote
1answer
147 views

SItecore 8.2.6 - IndexField attribute is not recognized in code

IndexField attribute is not recognized although Sitecore.ContentSearch.dll reference is added and namespace is included.
1
vote
3answers
1k views

Custom index field returning “Server Error in '/' Application. Could not find add method: AddComputedIndexField”

I am trying to create a commuted index field in sitecore 9 but can't get the configuration to work. I have a local environment which is running Solr and also environment is Azure. I have added the ...